HDU 5326 Work

Work

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 601    Accepted Submission(s): 401


Problem Description
HDU 5326 Work - NGUNAUJ - NGUNAUJ


It’s an interesting experience to move from ICPC to work, end my college life and start a brand new journey in company.
As is known to all, every stuff in a company has a title, everyone except the boss has a direct leader, and all the relationship forms a tree. If A’s title is higher than B(A is the direct or indirect leader of B), we call it A manages B.
Now, give you the relation of a company, can you calculate how many people manage k people. 
 

Input
There are multiple test cases.
Each test case begins with two integers n and k, n indicates the number of stuff of the company.
Each of the following n-1 lines has two integers A and B, means A is the direct leader of B.

1 <= n <= 100 , 0 <= k < n
1 <= A, B <= n
 

Output
For each test case, output the answer as described above.
 

Sample Input
    
    
7 2 1 2 1 3 2 4 2 5 3 6 3 7
 

Sample Output
    
    
2
 

Source
 

Recommend
wange2014   |   We have carefully selected several similar problems for you:   5325  5324  5323  5322  5321 
DFS 回溯的时候更新 具体看代码

/* ***********************************************
Author :
Created Time :2015/7/29 18:45:22
File Name :1.cpp
************************************************ */
#include <iostream>
#include <cstring>
#include <cstdlib>
#include <stdio.h>
#include <algorithm>
#include <vector>
#include <queue>
#include <set>
#include <map>
#include <string>
#include <math.h>
#include <stdlib.h>
#include <iomanip>
#include <list>
#include <deque>
#include <stack>
#define ull unsigned long long
#define ll long long
#define mod 90001
#define INF 1<<30
#define maxn 10000+10
#define cle(a) memset(a,0,sizeof(a))
const ull inf = 1LL << 61;
const double eps=1e-5;
using namespace std;

bool cmp(int a,int b){
return a>b;
}
int n,k;
vector<int>vec[maxn];
int sum[maxn];
int vis[maxn];
int fa[maxn];
int first;
void init(){
for(int i=1;i<=n;i++)
fa[i]=i;
}
int findfa(int x){
if(x==fa[x])return x;
else return fa[x]=findfa(fa[x]);
}

void dfs(int u){
for(int i=0;i<vec[u].size();i++){
int v=vec[u][i];
if(!vis[v]){
vis[v]=1;
dfs(v);
vis[v]=0;
sum[u]+=sum[v];
sum[u]++;
}
}
}
int main()
{
#ifndef ONLINE_JUDGE
freopen("in.txt","r",stdin);
#endif
//freopen("out.txt","w",stdout);
int a,b;
while(cin>>n>>k){
cle(sum);
cle(vis);
for(int i=0;i<=n;i++)
vec[i].clear();
for(int i=1;i<n;i++){
scanf("%d%d",&a,&b);
vec[a].push_back(b);
int x,y;
x=findfa(a);
y=findfa(b);
if(x!=y)fa[x]=y;
}
for(int i=1;i<=n;i++)
if(fa[i]!=i){
first=i;break;
}
dfs(first);// 改成dfs(1)也可以 数据比较弱,并查集是为了找根节点
int num=0;
for(int i=1;i<=n;i++){
if(sum[i]==k)num++;
}
printf("%d\n",num);
}
return 0;
}


moron
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值