题目描述
从键盘输入一行字符(长度小于100),统计其中单词的个数,各单词以空格分隔,且空格数可以是多个。
输入
输入只有一行句子。仅有空格和英文字母构成。
输出
单词的个数。
示例输入
stable marriage problem Consists of Matching members
示例输出
7
#include<stdio.h>
int main()
{
char a[81];
int i,n=0,w=0;
gets(a);
for(i=0;a[i]!='\0';i++)
if(a[i]==' ')
w=0;
else if(w==0)
{
w=1;
n++;
}
printf("%d\n",n);
return 0;
}