The ? 1 ? 2 ? ... ? n = k problem


 The ? 1 ? 2 ? ... ? n = k problem 

The problem

Given the following formula, one can set operators '+' or '-' instead of each '?', in order to obtain a given k
? 1 ? 2 ? ... ? n = k

For example: to obtain k = 12 , the expression to be used will be:
- 1 + 2 + 3 + 4 + 5 + 6 - 7 = 12
with n = 7

The Input

The first line is the number of test cases, followed by a blank line.

Each test case of the input contains integer k (0<=|k|<=1000000000).

Each test case will be separated by a single line.

The Output

For each test case, your program should print the minimal possible n (1<=n) to obtain k with the above formula.

Print a blank line between the outputs for two consecutive test cases.

Sample Input

2

12

-3646397

Sample Output

7

2701
#include<stdio.h>
int main()
{
    int i , n , j , sum , k ;
    scanf("%d", &n);
    for(i = 1 ; i <= n ; i++)
    {
        scanf("%d", &k);
        if(k<0)
        {k=-1*k;}
         if(k > 0)
        {
            sum = 0;
            for(j = 1 ; ; j++)
            {
                sum = sum + j;
                if(sum ==k || (sum > k && (sum-k)%2==0 ) )
                {
                    printf("%d\n", j);
                    break;
                }
            }
        }
        else
            printf("3\n");
        if(i!=n)
            printf("\n");
    }
    return 0;
}
这道题刚开始一看一点没思路。后来仔细思考了一下
他减去的都是偶数所以只要判断和比要求的数大于或等于
然后判断差值是否是偶数。
我开始的时候漏了k=0;的情况导致错误,很可惜。
 


评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值