zoj 3508 The War 贪心

士兵有一个拿武器的重量的范围,给出几种武器的重量,问如何才能让更多的士兵装备武器,求出最大的人数

Description

A war had broken out because a sheep from your kingdom ate some grasses which belong to your neighboring kingdom. The counselor of your kingdom had to get prepared for this war. There are N (1 <= N <= 2500) unarmed soldier in your kingdom and there are M (1 <= M <= 40000) weapons in your arsenal. Each weapon has a weight W (1 <= W <= 1000), and for soldier i, he can only arm the weapon whose weight is between minWi and maxWi ( 1 <= minWi <= maxWi <= 1000). More armed soldier means higher success rate of this war, so the counselor wants to know the maximal armed soldier he can get, can you help him to win this war?

Input

There multiple test cases. The first line of each case are two integers N, M. Then the following N lines, each line contain two integers minWi, maxWi for each soldier. Next M lines, each line contain one integer W represents the weight of each weapon.

Output

For each case, output one integer represents the maximal number of armed soldier you can get.

Sample Input

3 3
1 5
3 7
5 10
4
8
9
2 2
5 10
10 20
4
21

Sample Output

2
0
#include<stdio.h>
#include<string.h>
#include<algorithm>
using namespace std;
struct node
{
    int u,v;
} q[1000000];
int a[1000000];
int cmp(struct node x,struct node y)
{
    return x.v<y.v;
}
int main()
{
    int i,m,n,j,s;
    while(scanf("%d %d",&n,&m)!=EOF)
    {
        s=0;
        for(i=0; i<n; i++)
            scanf("%d %d",&q[i].u,&q[i].v);

        for(i=0; i<m; i++)
            scanf("%d",&a[i]);
            sort(q,q+n,cmp);
        sort(a,a+m);
        for(i=0; i<m; i++)
        {
            for(j=0; j<n; j++)
            {
                if(a[i]>=q[j].u&&a[i]<=q[j].v)
                {
                    q[j].u=0;
                    q[j].v=0;
                    s++;
                    a[i]=0;
                    break;
                }
            }
        }
        printf("%d\n",s);
    }
    return 0;
}



//这道题目就是每次是的士兵拿的的兵器是排序的最反的其实就是为了扩大可那的空间而已

#include<stdio.h>
#include<string.h>
#include<algorithm>
using namespace std;
struct node
{
    int u,v;
} q[1000000];
int a[1000000];
int cmp(struct node x,struct node y)
{
    return x.u>y.u;
}
int cmp2(int x,int y)
{
    return x>y;
}
int main()
{
    int i,m,n,j,s;
    while(scanf("%d %d",&n,&m)!=EOF)
    {
        s=0;
        for(i=0; i<n; i++)
            scanf("%d %d",&q[i].u,&q[i].v);

        for(i=0; i<m; i++)
            scanf("%d",&a[i]);
            sort(q,q+n,cmp);
        sort(a,a+m,cmp2);
        for(i=0; i<m; i++)
        {
            for(j=0; j<n; j++)
            {
                if(a[i]>=q[j].u&&a[i]<=q[j].v)
                {
                    q[j].u=0;
                    q[j].v=0;
                    s++;
                    a[i]=0;
                    break;
                }
            }
        }
        printf("%d\n",s);
    }
    return 0;
}

上面两个代码都是正确的
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值