poj1988 Cube Stacking 并查集

Description

Farmer John and Betsy are playing a game with N (1 <= N <= 30,000)identical cubes labeled 1 through N. They start with N stacks, each containing a single cube. Farmer John asks Betsy to perform P (1<= P <= 100,000) operation. There are two types of operations: 
moves and counts. 
* In a move operation, Farmer John asks Bessie to move the stack containing cube X on top of the stack containing cube Y. 
* In a count operation, Farmer John asks Bessie to count the number of cubes on the stack with cube X that are under the cube X and report that value. 

Write a program that can verify the results of the game. 

Input

* Line 1: A single integer, P 

* Lines 2..P+1: Each of these lines describes a legal operation. Line 2 describes the first operation, etc. Each line begins with a 'M' for a move operation or a 'C' for a count operation. For move operations, the line also contains two integers: X and Y.For count operations, the line also contains a single integer: X. 

Note that the value for N does not appear in the input file. No move operation will request a move a stack onto itself. 

Output

Print the output from each of the count operations in the same order as the input file. 

Sample Input

6
M 1 6
C 1
M 2 4
M 2 6
C 3
C 4

Sample Output

1
0
2
题意:有n个元素,开始每个元素自己一栈,有两种操作,将含有元素x的栈放在含有y的栈的顶端,合并为一个栈。第二种操作是询问含有x元素下面有多少个元素。
个人感觉这道题目老难了,我看了别人的代码自己都没搞懂最后还是自己模拟的才懂得。。。orz。。
#include<cstdio>
#include<iostream>
#include<algorithm>
#include<cstring>
using namespace std;
int set[300001],down[300001],num[300001];
int find(int x)
{
    if(set[x]!=x)
    {
        int y=set[x];
        set[x]=find(set[x]);
        down[x]+=down[y];
    }
    return set[x];
}
void get(int x,int y)
{
    int xx=find(x);
    int yy=find(y);
    if(xx!=yy)
    {
        set[xx]=yy;
        down[xx]+=num[yy];
        num[yy]+=num[xx];
    }
}
int main()
{
    int n;
    char ch;
    int m,l;
    while(~scanf("%d",&n))
    {
        for(int i=0; i<=n; i++)
        {
            set[i]=i;
            down[i]=0;
            num[i]=1;
        }

        while(n--)
        {
            getchar();
       scanf("%c",&ch);
            if(ch=='M')
            {
                scanf("%d %d",&m,&l);
                get(m,l);
            }
            else
            {
                scanf("%d",&m);
                find(m);
                printf("%d\n",down[m]);
            }
        }
    }
    return 0;
}


评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值