HDU 1796 How many integers can you find 容斥原理

题意:

      求1->n-1之间能被一个集合A内元素整除的数的个数,例如n = 12, A = {2, 3} 则能被A集合元素整除的数的集合为{2,  3, 4 , 6, 8, 9, 10}则结果为7。

解法:容斥定理,用回溯算法。

让我没想到的是用深搜来解决多重for循环问题

Description

  Now you get a number N, and a M-integers set, you should find out how many integers which are small than N, that they can divided exactly by any integers in the set. For example, N=12, and M-integer set is {2,3}, so there is another set {2,3,4,6,8,9,10}, all the integers of the set can be divided exactly by 2 or 3. As a result, you just output the number 7.
 

Input

  There are a lot of cases. For each case, the first line contains two integers N and M. The follow line contains the M integers, and all of them are different from each other. 0<N<2^31,0<M<=10, and the M integer are non-negative and won’t exceed 20.
 

Output

  For each case, output the number.
 

Sample Input

       
       
12 2 2 3
 

Sample Output

       
       
7
 

#include<cstdio>
#include<iostream>
#include<algorithm>
#include<cstring>
#include<math.h>
using namespace std;
long long a[20];
long long n,m;
long long ans;
long long gcd(long long a,long long b)
{
    return b==0?a:gcd(b,a%b);
}
void dfs(int c,int flag,long long lcm)
{
    lcm=a[c]/gcd(a[c],lcm)*lcm;
    if(flag) ans+=(n-1)/lcm;
    else
        ans-=(n-1)/lcm;
    for(int i=c+1; i<m; i++)
        dfs(i,!flag,lcm);
}
int main()
{
    while(~scanf("%lld %lld",&n,&m))
    {
        ans=0;
        for(int i=0; i<m; i++)
        {
            scanf("%lld",&a[i]);
            if(a[i]==0)
            {
                i--;
                m--;
            }
        }
        for(int i=0; i<m; i++)
            dfs(i,1,a[i]);
        printf("%lld\n",ans);

    }
    return 0;
}


  • 0
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值