1003

Problem C

Time Limit : 1000/1000ms (Java/Other)   Memory Limit : 32768/32768K (Java/Other)
Total Submission(s) : 10   Accepted Submission(s) : 5
Font: Times New Roman | Verdana | Georgia
Font Size: ← →

Problem Description

Happy new year to everybody!
Now, I want you to guess a minimum number x betwwn 1000 and 9999 to let
(1) x % a = 0;
(2) (x+1) % b = 0;
(3) (x+2) % c = 0;
and a, b, c are integers between 1 and 100.
Given a,b,c, tell me what is the number of x ?

Input

The number of test cases c is in the first line of input, then c test cases followed.every test contains three integers a, b, c.

Output

For each test case your program should output one line with the minimal number x, you should remember that x is between 1000 and 9999. If there is no answer for x, output "Impossible".

Sample Input

2
44 38 49
25 56 3

Sample Output

Impossible
2575

最小公倍数类型


代码


#include<iostream>
using namespace std;
int main()
{
    int t;
    int a,b,c;
    int n,k;
    cin>>t;
    while(t--&&cin>>a>>b>>c)
    {
        k=0;
        if(1000%a==0)
        n=1000/a;
        else n=1000/a+1;
        while((n*a+1)%b!=0||(n*a+2)%c!=0)
        {
            n++;
            if(n*a>9999)
            {
                k=1;
                cout<<"Impossible"<<endl;
                break;
            }
        }
        if(k==0)
        {
            cout<<n*a<<endl;
        }
    }
}

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值