HDU 3003 (二进制法)

Pupu

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 1040    Accepted Submission(s): 412


Problem Description
There is an island called PiLiPaLa.In the island there is a wild animal living in it, and you can call them PuPu. PuPu is a kind of special animal, infant PuPus play under the sunshine, and adult PuPus hunt near the seaside. They fell happy every day.

But there is a question, when does an infant PuPu become an adult PuPu?
Aha, we already said, PuPu is a special animal. There are several skins wraping PuPu's body, and PuPu's skins are special also, they have two states, clarity and opacity. The opacity skin will become clarity skin if it absorbs sunlight a whole day, and sunshine can pass through the clarity skin and shine the inside skin; The clarity skin will become opacity, if it absorbs sunlight a whole day, and opacity skin will keep sunshine out.

when an infant PuPu was born, all of its skins were opacity, and since the day that all of a PuPu's skins has been changed from opacity to clarity, PuPu is an adult PuPu.

For example, a PuPu who has only 3 skins will become an adult PuPu after it born 5 days(What a pity! The little guy will sustain the pressure from life only 5 days old)

Now give you the number of skins belongs to a new-laid PuPu, tell me how many days later it will become an adult PuPu?
 

Input
There are many testcase, each testcase only contains one integer N, the number of skins, process until N equals 0
 

Output
Maybe an infant PuPu with 20 skins need a million days to become an adult PuPu, so you should output the result mod N
 

Sample Input
  
  
2 3 0
 

Sample Output
  
  
1 2
 

输入的数字是层数,讲其看为二进制的层数,从左到右,则
2为0 0-》1 0-》0 1  三天
3为0 0 0-》1 0 0-》0 1 0 -》1 1 0 -》0 0 1  五天
4为0 0 0 0-》1 0 0 0-》0 1 0 0-》1 1 0 0-》0 0 1 0-》1 0 1 0-》0 1 1 0-》1 1 1 0-》0 0 0 1 九天
需要的天数都为(2^n-1)+1
所以可以讲题意理解为求((2^n-1)%n+1)%n

#include<iostream>
#include<cstdio>
#include<cstring>
using namespace std;
int main()
{
    __int64 a,b,s,aa;
    while(scanf("%I64d",&a)&&a)
    {
        b=a-1;
        s=1;
        aa=2;
        while(b)
        {
            if(b%2) s=(s*aa)%a;
            aa=(aa*aa)%a;
            b/=2;
        }
        s+=1;
        if(a>1)
        cout<<s<<endl;
        else cout<<a-1<<endl; //第一天为特殊
    }
}
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值