HDU 2602 简单0-1背包问题

Bone Collector

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 32116    Accepted Submission(s): 13224


Problem Description
Many years ago , in Teddy’s hometown there was a man who was called “Bone Collector”. This man like to collect varies of bones , such as dog’s , cow’s , also he went to the grave …
The bone collector had a big bag with a volume of V ,and along his trip of collecting there are a lot of bones , obviously , different bone has different value and different volume, now given the each bone’s value along his trip , can you calculate out the maximum of the total value the bone collector can get ?

 

Input
The first line contain a integer T , the number of cases.
Followed by T cases , each case three lines , the first line contain two integer N , V, (N <= 1000 , V <= 1000 )representing the number of bones and the volume of his bag. And the second line contain N integers representing the value of each bone. The third line contain N integers representing the volume of each bone.
 

Output
One integer per line representing the maximum of the total value (this number will be less than 2 31).
 

Sample Input
  
  
1 5 10 1 2 3 4 5 5 4 3 2 1
 

Sample Output
  
  
14
 

将v体积的物品放入到背包中,若不能放入  则背包内价值不变,否则则取

max(v[i-1][V],v[i-1][V-v]+m[i])


#include<iostream>
#include<algorithm>
#include<cstdio>
using namespace std;
int v[1010][1010];
struct ssss
{
    int m,v;
}ss[1010];
/*bool compare(ssss a,ssss b)
{
    return a.v<b.v;
}*/
int main()
{
    int n;
    scanf("%d",&n);
    while(n--)
    {
        int V,t;
        scanf("%d%d",&t,&V);
        for(int i=1;i<=t;i++)
        scanf("%d",&ss[i].m);
        for(int i=1;i<=t;i++)
        scanf("%d",&ss[i].v);
        //sort(ss,ss+t,compare);
        for(int i=0;i<=V;i++)
        for(int j=0;j<=V;j++)
        v[i][j]=0;
        for(int i=1;i<=t;i++)
        {
            for(int j=V;j>=0;j--)
            {
                if(j<ss[i].v)
                {
                    v[i][j]=v[i-1][j];
                    continue ;
                }
                if(v[i-1][j]<v[i-1][j-ss[i].v]+ss[i].m)
                v[i][j]=v[i-1][j-ss[i].v]+ss[i].m;
                else v[i][j]=v[i-1][j];
            }
        }
        cout<<v[t][V]<<endl;
    }
}

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值