【Java错误解决方案】解决IDEA创建Java工程并运行的时候出现“java: 错误: 不支持发行版本 5 | java: 错误: 不支持发行版本 6”的问题

【Java错误解决方案】解决IDEA创建Java工程运行的时候出现“java: 错误: 不支持发行版本 5 | java: 错误: 不支持发行版本 6”的问题

问题描述

IDEA创建Java工程运行的时候出现“java: 错误: 不支持发行版本 5 | java: 错误: 不支持发行版本 6”的问题,出现以下报错信息

在这里插入图片描述

解决方案

需要在IDEA中打开File > Settings > Build, Execution, Deployment > Compiler > Java Compiler 节点下,做如下修改,将Target bytecode version 的版本号改成8、11、17都行,改完以后保存,再次运行即可

修改前

在这里插入图片描述


修改后


在这里插入图片描述

  • 6
    点赞
  • 6
    收藏
    觉得还不错? 一键收藏
  • 2
    评论
当在使用IntelliJ IDEA运行Java项目时,出现"java: 错误: 不支持发行版本 5"的错误提示,这通常是由于项目的Java版本IDEA配置的Java版本不一致导致的。解决这个问题的方法如下: 1. 确认项目的Java版本:打开项目中的pom.xml文件(如果是Maven项目)或build.gradle文件(如果是Gradle项目),查找并确认项目使用的Java版本。例如,如果项目使用的是Java 8,则应该在配置文件中找到类似以下的配置: ``` <properties> <maven.compiler.source>1.8</maven.compiler.source> <maven.compiler.target>1.8</maven.compiler.target> </properties> ``` 或者 ``` sourceCompatibility = 1.8 targetCompatibility = 1.8 ``` 2. 确认IDEAJava版本:打开IntelliJ IDEA,点击菜单栏中的"File" -> "Project Structure",在弹出的窗口中选择"Project",然后确认"Project SDK"的设置与项目所需的Java版本一致。如果没有安装对应版本Java SDK,可以点击右侧的"New"按钮来安装并配置。 3. 更新IDEA的编译器设置:在IntelliJ IDEA中,点击菜单栏中的"File" -> "Settings",在弹出的窗口中选择"Build, Execution, Deployment" -> "Compiler",然后将"Target bytecode version"设置为与项目所需的Java版本一致。 4. 重新构建项目:完成上述步骤后,尝试重新构建项目并运行,看是否还会出现相同的错误。 如果以上方法仍然无法解决问题,请提供更多关于你的项目和IDEA配置的详细信息,以便我能够给出更准确的解决方案

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论 2
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值