openwrt-mt7688 中继调试

一、概述

AP,即Access Point Mode,允许无线接入,家里的无线路由器,大部都是这个模式。 

STA,即Station Mode,作为无线终端,连接AP用,手机wifi等,大部都是这个模式。 
AP+STA配置,使得OpenWrt路由器,既能提供无线接入功能的AP,又能连接到其他AP,继续提供上网功能,即作为一个Repeater。 

完成AP+STA配置,首先需要硬件支持,确认支持AP+STA。

二、配置编译选项

1、AP模式:配置wifi AP driver

      MTK Properties  ---> Drivers  --->  kmod-mt7628.................................... MTK MT7628 wifi AP driver

2、STA模式:配置 AP client

     MTK Properties --->Drivers --->

     kmod-mt7628.................................... MTK MT7628 wifi AP driver --->

     WiFi Operation   Modes  --->   AP-Client Support
3、确认uci2dat已结选中(默认是已经选中的)
      MTK Properties  ---> Applications ---> uci2dat
      据说这有个大坑,mtk提供的uci2dat工具是不能解析uci配置的ApCli字段的,下载下面的uci2dat。

      将openwrt-sdk/package/ramips/applications的uci2dat备份为uci2dat.bak,以防之后要用,

      并将下载的uci2dat替换它。

       http://blog.chinaunix.net/blog/downLoad/fileid/11614.html

4、重新编译内核并烧录

三、查看AP info

1、用ifconfig查看,发现多了ra0,为AP的信息

     用iwconfig查看

     释放的热点SSID为 "mt7628-601A",默认密码为"12345678";
     现在就可以你的WIFI设备连接上7688释放的热点上啦!但是上不了外网哦

2、/etc/config/wireless,可修改SSID、password等信息
       
config wifi-iface
option device   mt7628
option ifname   ra0
option network  lan
option mode     ap
option ssid     mt7628-601A
option encryption psk2
option key      12345678
     /etc/config/network 
     
config interface 'lan'
option ifname 'eth0.1'
option force_link '1'
option type 'bridge'
option proto 'static'
option ipaddr '192.168.1.1'     <---注意,这个LAN的IP,也是AP时的IP,作为STA模式时,连接的
                                    网关也可能是192.168.0.X或192.168.1.X等常用的地址,要
                                    保证AP模式的IP与STA连接的网关在不同网段。所以这里以
                                    192.168.2.X为例。
option netmask '255.255.255.0'
option ip6assign '60'
option macaddr '7C:DD:90:A4:60:1A'

可通过以下指令来扫描当前环境下的路由列表
iwpriv apcli0 set SiteSurvey=0
        sleep 2
        iwpriv apcli0 get_site_survey


四、配置ApCli0

1、在wireless中给ra0添加以下字段,要注意区分大小写
   
config wifi-iface
option device   mt7628
option ifname   ra0
option network  lan
option mode     ap
option ssid     mt7628-601A
option encryption psk2
option key      12345678
option ApCliEnable     '1'          -->开启ApCli
option ApCliSsid       'wpa2_test'  -->上级路由的SSID
option ApCliAuthMode   'WPA2PSK'    -->上级路由的authmode
option ApCliEncrypType 'AES'        -->上级路由的加密
option ApCliWPAPSK     '123456789'  -->上级路由的密码

2、把wireless中wifi-device的channel改成与上级路由的一致
3、注意本级Ap的网段必须与上级AP网段不同,
     可在network下修改interface 'lan’的ipaddr字段
4、将ApCli0添加到network的 interface 'wan'的 ifname 'apcli0'

五、重启网络

/etc/init.d/network restart
ifconfig apcli0可以查看是否连接上上级AP,成功连接会获取IP地址
iwconfig apcli0可以看到连接的上级AP的SSID、channel等信息
最后ping www.baidu.com试试能否上外网啦
展开阅读全文

没有更多推荐了,返回首页