Hdu 5305 Friends 2015 Multi-University Training Contest 2

http://acm.hdu.edu.cn/showproblem.php?pid=5305

Friends

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/65536 K (Java/Others)
Total Submission(s): 204    Accepted Submission(s): 88


Problem Description
There are  n  people and  m  pairs of friends. For every pair of friends, they can choose to become online friends (communicating using online applications) or offline friends (mostly using face-to-face communication). However, everyone in these  n  people wants to have the same number of online and offline friends (i.e. If one person has  x  onine friends, he or she must have  x  offline friends too, but different people can have different number of online or offline friends). Please determine how many ways there are to satisfy their requirements. 
 

Input
The first line of the input is a single integer  T (T=100) , indicating the number of testcases. 

For each testcase, the first line contains two integers  n (1n8)  and  m (0mn(n1)2) , indicating the number of people and the number of pairs of friends, respectively. Each of the next  m  lines contains two numbers  x  and  y , which mean  x  and  y  are friends. It is guaranteed that  xy  and every friend relationship will appear at most once. 
 

Output
For each testcase, print one number indicating the answer.
 

Sample Input
  
  
2 3 3 1 2 2 3 3 1 4 4 1 2 2 3 3 4 4 1
 

Sample Output
  
  
0 2
 


// 暴搜即可,加相关定义的剪纸。
#include<iostream>
#include<algorithm>
#include<cstdio>
#include<cstring>
#include<string>
using namespace std;
int ans;
int n,m;
int cnt[10];
struct node{
    int x,y;
    void in(){
        scanf("%d%d",&x,&y);
        if(x>y)swap(x,y);
        cnt[x]++;
        cnt[y]++;
    }
    friend bool operator < (node a,node b){
        if(a.x==b.x)return a.y<b.y;
        return a.x<b.x;
    }
}p[30];
void dfs(int t,int on[],int off[]){
    if(t==m){
        ans++;
        return ;
    }
    int x=p[t].x;
    int y=p[t].y;
    on[x]++ , on[y]++;
    if(on[x]<=cnt[x]/2 && off[x]<=cnt[x]/2 && on[y]<=cnt[y]/2 && off[y]<=cnt[y]/2 ){
        dfs(t+1,on,off);
    }
    on[x]-- , on[y]--;
    off[x]++ , off[y]++;
    if(on[x]<=cnt[x]/2 && off[x]<=cnt[x]/2 && on[y]<=cnt[y]/2 && off[y]<=cnt[y]/2 ){
        dfs(t+1,on,off);
    }
    off[x]-- , off[y]-- ;
}
int main(){
    int T;scanf("%d",&T);
    while(T--){
        scanf("%d%d",&n,&m);
        int on[10];
        int off[10];
        memset(cnt,0,sizeof cnt);
        memset(on,0,sizeof on);
        memset(off,0,sizeof off);
        for(int i=0;i<m;i++){
            p[i].in();
        }
        bool ok=false;
        for(int i=1;i<=n;i++){
            if(cnt[i]&1){
                ok=true;
                break;
            }
        }
        if(ok){
            printf("0\n");
            continue;
        }
        sort(p,p+m);
        ans=0;
        dfs(0,on,off);
        printf("%d\n",ans);
    }
    return 0;
}



Source
 
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值