【HDU1003】【Max Sum】【2种代码】

Max Sum

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 177615    Accepted Submission(s): 41422


Problem Description
Given a sequence a[1],a[2],a[3]......a[n], your job is to calculate the max sum of a sub-sequence. For example, given (6,-1,5,4,-7), the max sum in this sequence is 6 + (-1) + 5 + 4 = 14.
 

Input
The first line of the input contains an integer T(1<=T<=20) which means the number of test cases. Then T lines follow, each line starts with a number N(1<=N<=100000), then N integers followed(all the integers are between -1000 and 1000).
 

Output
For each test case, you should output two lines. The first line is "Case #:", # means the number of the test case. The second line contains three integers, the Max Sum in the sequence, the start position of the sub-sequence, the end position of the sub-sequence. If there are more than one result, output the first one. Output a blank line between two cases.
 

Sample Input
  
  
2 5 6 -1 5 4 -7 7 0 6 -1 1 -6 7 -5
 

Sample Output
  
  
Case 1: 14 1 4 Case 2: 7 1 6
 

Author
Ignatius.L
 

Recommend

#include <iostream>
#include <cstring>
#include <cmath>
#include <queue>
#include <stack>
#include <list>
#include <map>
#include <set>
#include <string>
#include <cstdlib>
#include <cstdio>
#include <algorithm>
using namespace std;

int T;
int N;
const int maxn = 100010;
int a[maxn];
int dp[maxn];
int path[maxn];
int main()
{
	scanf("%d",&T);
	int Case = 1;
	while(T --)
	{

		scanf("%d",&N);
		for(int i=1;i<=N;i++)
		{
			scanf("%d",&a[i]);
		}
		memset(dp,-0x3f3f3f3f,sizeof(dp));
		dp[0] = 0;
		path[0] = 1;
		for(int i=1;i<=N;i++)
		{
			if(a[i] > dp[i-1] + a[i])
			{
				path[i] = i;
			}
			else 
			{
				path[i] = path[i-1];
			}
			dp[i] = max(a[i],dp[i-1] + a[i]);
		}
		int maxs = -0x3f3f3f3f;
		int r,l;
		for(int i=1;i<=N;i++)
		{
			if(dp[i] > maxs) 
			{
				maxs = dp[i];
				l = path[i];
				r = i;
			}
		}
		if(Case >= 2)
		{

			printf("\n");
		}
		printf("Case %d:\n",Case++);
		printf("%d %d %d\n",maxs,l,r);
		

	}
	return 0;
}


#include <iostream>
#include <cstring>
#include <cmath>
#include <queue>
#include <stack>
#include <list>
#include <map>
#include <set>
#include <string>
#include <cstdlib>
#include <cstdio>
#include <algorithm>
using namespace std;
    
int T;
int main()
{
	int C = 1;
    scanf("%d",&T);
	int n;
	int c,s,p,l,r,ans;
	while(T--)
	{
		c = ans = -0x3f3f3f3f;
		scanf("%d",&n);
		for(int i=0;i<n;i++)
		{
			scanf("%d",&s);
		   if(c >= 0) c += s; else {c = s,p=i;}
		   if(c > ans)
		   {
			   ans = c;
			   l = p;
			   r = i;
		   }
		}
		printf("Case %d:\n%d %d %d\n%s",C++,ans,l+1,r+1,T==0?"":"\n");

		
	}
    return 0;
}





  • 0
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值