【HDU3652】【B-number】

28 篇文章 0 订阅
18 篇文章 0 订阅

B-number

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 3241    Accepted Submission(s): 1811


Problem Description
A wqb-number, or B-number for short, is a non-negative integer whose decimal form contains the sub- string "13" and can be divided by 13. For example, 130 and 2613 are wqb-numbers, but 143 and 2639 are not. Your task is to calculate how many wqb-numbers from 1 to n for a given integer n.
 

Input
Process till EOF. In each line, there is one positive integer n(1 <= n <= 1000000000).
 

Output
Print each answer in a single line.
 

Sample Input
  
  
13 100 200 1000
 

Sample Output
  
  
1 1 2 2
 

Author
wqb0039
 

Source
 

Recommend
lcy


#include <iostream>
#include <cstring>
#include <cmath>
#include <queue>
#include <stack>
#include <list>
#include <map>
#include <set>
#include <string>
#include <cstdlib>
#include <cstdio>
#include <algorithm>
using namespace std;

typedef long long ll;

ll dp[25][10][13][2]; // 0:
ll bits[25];
ll dfs(ll pos,ll p,ll mod,bool ok,bool flag)
{
	if(pos <= 0) return (mod == 0 && ok) ? 1 : 0; 
	if(!flag && ~dp[pos][p][mod][ok]) return dp[pos][p][mod][ok];
	ll end = flag ? bits[pos] : 9;
	ll res = 0;
	for(int i=0;i<=end;i++)
	{
		ll tmp = (mod*10 + i) % 13;
		//	tmp = (13 - tmp) % 13;
		res += dfs(pos-1,i,tmp,ok || (p == 1 && i == 3),flag && (i==end));
	}
	return flag ? res : dp[pos][p][mod][ok] = res;
}
ll solve(ll x)
{
	ll cur = 0;
	ll tt =x ;
	while(tt > 0)
	{
		bits[++cur] = tt % 10;
		tt /= 10;
	}
	return dfs(cur,0,0,0,1);
}
int main()
{
	ll n;
	memset(dp,-1,sizeof(dp));	
	while(scanf("%I64d",&n) != EOF)
	{
		printf("%I64d\n",solve(n));		
	}
	return 0;
}


  • 0
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值