【HDU3974】【并查集】【技巧】【代码短时间快】

Assign the task

Time Limit: 15000/5000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 1197    Accepted Submission(s): 563


Problem Description
There is a company that has N employees(numbered from 1 to N),every employee in the company has a immediate boss (except for the leader of whole company).If you are the immediate boss of someone,that person is your subordinate, and all his subordinates are your subordinates as well. If you are nobody's boss, then you have no subordinates,the employee who has no immediate boss is the leader of whole company.So it means the N employees form a tree.

The company usually assigns some tasks to some employees to finish.When a task is assigned to someone,He/She will assigned it to all his/her subordinates.In other words,the person and all his/her subordinates received a task in the same time. Furthermore,whenever a employee received a task,he/she will stop the current task(if he/she has) and start the new one.

Write a program that will help in figuring out some employee’s current task after the company assign some tasks to some employee.
 

Input
The first line contains a single positive integer T( T <= 10 ), indicates the number of test cases.

For each test case:

The first line contains an integer N (N ≤ 50,000) , which is the number of the employees.

The following N - 1 lines each contain two integers u and v, which means the employee v is the immediate boss of employee u(1<=u,v<=N).

The next line contains an integer M (M ≤ 50,000).

The following M lines each contain a message which is either

"C x" which means an inquiry for the current task of employee x

or

"T x y"which means the company assign task y to employee x.

(1<=x<=N,0<=y<=10^9)
 

Output
For each test case, print the test case number (beginning with 1) in the first line and then for every inquiry, output the correspond answer per line.
 

Sample Input
  
  
1 5 4 3 3 2 1 3 5 2 5 C 3 T 2 1 C 3 T 3 2 C 3
 

Sample Output
  
  
Case #1: -1 1 2
 

Source
 

Recommend



#include <iostream>
#include <cstring>
#include <cmath>
#include <queue>
#include <stack>
#include <list>
#include <map>
#include <string>
#include <cstdlib>
#include <cstdio>
#include <algorithm>
using namespace std;
    
#define rep(i,a,n) for (int i=a;i<n;i++)
#define per(i,a,n) for (int i=n-1;i>=a;i--)
#define mp push_back

int T,n,m;
struct Node
{
	int task;
	int time;
}p[50010];
int parent[50010];

char str[2];
int main()
{
	freopen("in.txt","r",stdin);
	scanf("%d",&T);
	int C = 1;
	while(T --)
	{
		printf("Case #%d:\n", C++);
		scanf("%d",&n);
		int cnt = 0;
		memset(parent,-1,sizeof(parent));
		for(int i=1;i<=n;i++)
		{
			p[i].task = -1;
			p[i].time = -1;
		}
		for(int i=0;i<n-1;i++)
		{
			int u,v;
			scanf("%d%d",&u,&v);
			parent[u] = v;
		}
		scanf("%d",&m);
		for(int i=0;i<m;i++)
		{
			scanf("%s",str);
			if(str[0] == 'C')
			{
				int u;
				scanf("%d",&u);
				int ans = p[u].task;
				int time = p[u].time;
				int tt = u;
				while(tt != -1)
				{
					if(p[tt].time > time)
					{
						time = p[tt].time;
						ans = p[tt].task;
					}
					tt = parent[tt];
				}
				printf("%d\n",ans);
			}
			else
			{
				int pos,t;
				scanf("%d%d",&pos,&t);
				p[pos].time = ++cnt ;
				p[pos].task = t;
				//cout << "#" << pos << " " << t << endl;
			}
		}	
	}
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值