Ugly Numbers

Ugly Numbers
时间限制: 1 Sec  内存限制: 128 MB
题目描述
Ugly numbers are numbers whose only prime factors are 2, 3 or 5. The sequence 1, 2, 3, 4, 5, 6, 8, 9, 10, 12, ... shows the first 10 ugly numbers. By convention, 1 is included. Given the integer n,write a program to find and print the n‘th ugly number.
输入
Each line of the input contains a postisive integer n (n <= 1500).Input is terminated by a line with n=0.
输出
For each line, output the n’th ugly number .:Don’t deal with the line with n=0.
样例输入
1
2
9
0
样例输出
1
2

10


// Ugly Numbers
//只能被2,3,5整除,1,2,3,4,5,6,8,9,10...
#include <stdio.h>
//在已知第一个丑数基础上,分别进行*2,*3,*5操作,然后取最小的依次放入数组
//即可避免所有数字暴力穷举选择 
int twoNum = 0, threeNum = 0, fiveNum = 0;
int ugly[1500];
void create()
{
    ugly[0] = 1;
    for (int i = 1; i < 1500; i++) {
        int min = ugly[twoNum] * 2, b = ugly[threeNum] * 3, c = ugly[fiveNum] * 5;
        if (b < min) {
            min = b;
        }
        if (c < min) {
            min = c;
        }
        ugly[i] = min;
        if (ugly[i] == ugly[twoNum] * 2) {
            twoNum++;
        }
        if (ugly[i] == ugly[threeNum] * 3) {
            threeNum++;
        }
        if (ugly[i] == ugly[fiveNum] * 5) {
            fiveNum++;
        }
    }
}
 
int main()
{
    create();
    int n;
    while (scanf("%d", &n) != EOF) {
        if (n == 0) {
            return 0;
        }
        printf("%d\n", ugly[n - 1]);
    }
    return 0;
}

  • 1
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值