最长连续递增子序列

习题3.4 最长连续递增子序列   (20分)

给定一个顺序存储的线性表,请设计一个算法查找该线性表中最长的连续递增子序列。例如,(1,9,2,5,7,3,4,6,8,0)中最长的递增子序列为(3,4,6,8)。

输入格式:

输入第1行给出正整数nn\le 10^5105);第2行给出nn个整数,其间以空格分隔。

输出格式:

在一行中输出第一次出现的最长连续递增子序列,数字之间用空格分隔,序列结尾不能有多余空格。

输入样例:

15
1 9 2 5 7 3 4 6 8 0 11 15 17 17 10

输出样例:

3 4 6 8

#include <stdio.h>

#define N 100

int main(){

	int i,n,from=0,to=0,len=0,tfrom=0,tto=0,tlen=0,Data[N];

	scanf("%d", &n);

	for(i=0;i<n;i++)
		scanf("%d", &Data[i]);

	for(i=0;i<n;i++){
		if(Data[i]<Data[i+1]){
			tto++;
		}else{
			tlen=tto-tfrom+1;
			printf("tfrom = %d, tto = %d, tlen = %d\n", tfrom, tto, tlen);
			if(tlen>len){
				from=tfrom;
				to=tto;
				len=to-from+1;
				printf("from = %d, to = %d, len = %d\n", from, to, len);
				tfrom=tto=i+1;
			}else{
				tfrom=tto=i+1;
			}
		}
	}

	for(i=from;i<=to;i++)
		printf("%d ", Data[i]);
	printf("\n");
	
	return 0;
}




  • 0
    点赞
  • 2
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值