递推—杭电1297 Children’s Queue

http://acm.hdu.edu.cn/showproblem.php?pid=1297

Children’s Queue

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 10127    Accepted Submission(s): 3232

Problem Description
There are many students in PHT School. One day, the headmaster whose name is PigHeader wanted all students stand in a line. He prescribed that girl can not be in single. In other words, either no girl in the queue or more than one girl stands side by side. The case n=4 (n is the number of children) is like
FFFF, FFFM, MFFF, FFMM, MFFM, MMFF, MMMM
Here F stands for a girl and M stands for a boy. The total number of queue satisfied the headmaster’s needs is 7. Can you make a program to find the total number of queue with n children?
 
Input
There are multiple cases in this problem and ended by the EOF. In each case, there is only one integer n means the number of children (1<=n<=1000)
 
Output
For each test case, there is only one integer means the number of queue satisfied the headmaster’s needs.
 
Sample Input
  
  
1 2 3
 
Sample Output
  
  
1 2 4

 

#include<iostream>
#include<string> 
using namespace std;
string add(string s1,string s2)
{
    
    int j,l,la,lb;
    string max,min;
    max=s1;
    min=s2;
    if(s1.length()<s2.length()) 
    {
        max=s2;
        min=s1;
    }//保证max是最长的一个数
    la=max.size();
    lb=min.size();
    l=la-1;
    for(j=lb-1;j>=0;j--,l--) 
        max[l] += min[j]-'0'; //使对应每位数相加
    for(j=la-1;j>=1;j--) 
        if(max[j]>'9')//如果当前位数大于9,当前数减10,向前一位进1
        {
            max[j]-=10;
            max[j-1]++;
        }
        if(max[0]>'9') 
        {
            max[0]-=10;
            max='1'+max;
        }
        return max;
}
int main(){
    int n,i;
    string a[1001];
    a[0]="1";
    a[1]="1";
    a[2]="2";
    a[3]="4";
    for(i=4;i<1001;++i)
        a[i]=add(add(a[i-1],a[i-2]),a[i-4]);//每两个数一调用大数相加模板
    while(cin>>n)
        cout<<a[n]<<endl;
    return 0;      
}

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值