动态规划—杭电1160 FatMouse's Speed

http://acm.hdu.edu.cn/showproblem.php?pid=1160

FatMouse's Speed

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 8645    Accepted Submission(s): 3837
Special Judge


Problem Description

 

FatMouse believes that the fatter a mouse is, the faster it runs. To disprove this, you want to take the data on a collection of mice and put as large a subset of this data as possible into a sequence so that the weights are increasing, but the speeds are decreasing.
 


 

Input

 

Input contains data for a bunch of mice, one mouse per line, terminated by end of file.

The data for a particular mouse will consist of a pair of integers: the first representing its size in grams and the second representing its speed in centimeters per second. Both integers are between 1 and 10000. The data in each test case will contain information for at most 1000 mice.

Two mice may have the same weight, the same speed, or even the same weight and speed.  
 


 

Output

 

Your program should output a sequence of lines of data; the first line should contain a number n; the remaining n lines should each contain a single positive integer (each one representing a mouse). If these n integers are m[1], m[2],..., m[n] then it must be the case that  

W[m[1]] < W[m[2]] < ... < W[m[n]]

and  

S[m[1]] > S[m[2]] > ... > S[m[n]]

In order for the answer to be correct, n should be as large as possible.
All inequalities are strict: weights must be strictly increasing, and speeds must be strictly decreasing. There may be many correct outputs for a given input, your program only needs to find one.  
 


 

Sample Input

 

  
  
6008 1300 6000 2100 500 2000 1000 4000 1100 3000 6000 2000 8000 1400 6000 1200 2000 1900
 


 

Sample Output

 

  
  
4 4 5 9 7


 

#include<iostream>
#include<algorithm>
using namespace std;
int dp[1001];
int pre[1001];//记录i对应的上一个数据
int res[1001];//存放最终结果下标 
struct Node
{
    int w,s;//重量和速度 
    int index;//最初的序号,避免排序后乱掉顺序,后面需要输出的 
}mouse[1001];
bool cmp(Node a,Node b)//先按照w从小到大排序,再按照y从大到小排序 
{
    if(a.w<b.w)  return 1;
    else if(a.w==b.w&&a.s>b.s)return 1;
    else return 0;
}    

int main()
{
    int i=1,j;
    while(scanf("%d%d",&mouse[i].w,&mouse[i].s)!=EOF)
    {
        dp[i]=1;
        pre[i]=0;
        mouse[i].index=i;
        i++;
    }    
    int n=i-1;
    sort(mouse+1,mouse+i,cmp);
    int maxlen=0;//最长序列长度 
    int maxi;//最长序列的最后一个数下标 
    dp[1]=1;
    for(i=1;i<=n;i++)
    {
        for(j=1;j<i;j++)
            if(mouse[i].w>mouse[j].w&&mouse[i].s<mouse[j].s&&dp[j]+1>dp[i])
            {
                 dp[i]=dp[j]+1;//dp[i]表示以第i个数据结尾的符合要求的子列长度
                 pre[i]=j;
                 if(dp[i]>maxlen)
                 {
                       maxi=i;
                       maxlen=dp[i];                      
                 }    
            }                 
    }
    int t=maxi;
    i=0;
    while(t!=0)
    {
        res[i++]=t;
        t=pre[t];
    } 
    cout<<i<<endl;
    while(i>0)
    {
        i--;
        cout<<mouse[res[i]].index<<endl;
    }  
    return 0;             
}

  • 1
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 1
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论 1
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值