POJ 2299 Ultra-QuickSort

Ultra-QuickSort
Time Limit: 7000MS Memory Limit: 65536K
Total Submissions: 40008 Accepted: 14432

Description

In this problem, you have to analyze a particular sorting algorithm. The algorithm processes a sequence of n distinct integers by swapping two adjacent sequence elements until the sequence is sorted in ascending order. For the input sequence 
9 1 0 5 4 ,

Ultra-QuickSort produces the output 
0 1 4 5 9 .

Your task is to determine how many swap operations Ultra-QuickSort needs to perform in order to sort a given input sequence.

Input

The input contains several test cases. Every test case begins with a line that contains a single integer n < 500,000 -- the length of the input sequence. Each of the the following n lines contains a single integer 0 ≤ a[i] ≤ 999,999,999, the i-th input sequence element. Input is terminated by a sequence of length n = 0. This sequence must not be processed.

Output

For every input sequence, your program prints a single line containing an integer number op, the minimum number of swap operations necessary to sort the given input sequence.

Sample Input

5
9
1
0
5
4
3
1
2
3
0

Sample Output

6
0


搜索思想 超时

#include <iostream>//由小到大排序
using namespace std;
int s[500005];
int main()
{
    int i, j;
    int n;
    while(cin>>n&&n)
	{
		for(i=1;i<=n;i++)
			cin>>s[i];
		int sum=0;
		int temp;
		for(i=1;i<n;i++)
			for(j=1;j<n;j++)
				if(s[j]>s[j+1])
				{
					sum=sum+1;
					temp=s[j];
					s[j]=s[j+1];
					s[j+1]=temp;
				}
				cout<<sum<<endl;
	}
	return 0;
}

分冶思想——归并排序

#include <iostream>
using namespace std;
const int n=500000;
int a[n],b[n];
unsigned __int64 sum;
void merge(int p,int q,int r)
{
	int begin_a=p,begin_b=q+1,t=p;
	for(;begin_a<=r;begin_a++)
		b[begin_a]=a[begin_a];
	begin_a=p;
	while((begin_a<=q) && (begin_b<=r))
	{
		if(b[begin_a]<=b[begin_b])
		{
			a[t++]=b[begin_a++];
		}
		else
		{
			a[t++]=b[begin_b++];
			sum+=q-begin_a+1;
		}
	}
	while(begin_a<=q)
		a[t++]=b[begin_a++];
	while(begin_b<=r)
		a[t++]=b[begin_b++];
}
void mergeSort(int low,int high)
{
	if(low<high)
	{
		int mid=(low+high)/2;
		mergeSort(low,mid);
		mergeSort(mid+1,high);
		merge(low,mid,high);
	}
}
int main()
{
	int i,m;
	while(scanf("%d",&m) && m!=0)
	{
		for(i=0;i<m;i++)
			scanf("%d",&a[i]);
		sum=0;
		mergeSort(0,m-1);
		printf("%I64d\n",sum);
	}
	return 0;
}





  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值