POJ 1159 Palindrome(lcs加滚动数组)

Palindrome
Time Limit: 3000MS Memory Limit: 65536K
Total Submissions: 52350 Accepted: 18041

Description

A palindrome is a symmetrical string, that is, a string read identically from left to right as well as from right to left. You are to write a program which, given a string, determines the minimal number of characters to be inserted into the string in order to obtain a palindrome. 

As an example, by inserting 2 characters, the string "Ab3bd" can be transformed into a palindrome ("dAb3bAd" or "Adb3bdA"). However, inserting fewer than 2 characters does not produce a palindrome. 

Input

Your program is to read from standard input. The first line contains one integer: the length of the input string N, 3 <= N <= 5000. The second line contains one string with length N. The string is formed from uppercase letters from 'A' to 'Z', lowercase letters from 'a' to 'z' and digits from '0' to '9'. Uppercase and lowercase letters are to be considered distinct.

Output

Your program is to write to standard output. The first line contains one integer, which is the desired minimal number.

Sample Input

5
Ab3bd

Sample Output

2

设原序列S的逆序列为S' ,则这道题目的关键在于,

最少需要补充的字母数 = 原序列S的长度 —  S和S'的最长公共子串长度


刚开始做的时候没有想到滚动数组,结果就mle了。。(后来听说改成short int ,结果就ac了)空间开销很大

#include <iostream>
#include <cstring>
using namespace std;

#define maxn 5005
char str[maxn];//输入的字符串
char nstr[maxn];//输入的字符串的逆序列
short int dp[maxn][maxn];//定义动态二维数组并初始化

int main()
{
    int n;//输入的字符串长度
    cin>>n;
		
    dp[0][0]=0;
    memset(dp,0,sizeof(dp));
	
    int i,j;
    for(i=1,j=n;i<=n&&j>=1;i++,j--)
    {
        cin>>str[i];
        nstr[j]=str[i];//给逆序列赋值
    }
	
    for(i=1;i<=n;i++)
        for(j=1;j<=n;j++)
        {
            if(str[i]==nstr[j])//如果字符相等,dp[i][j]等于左上值加1
                dp[i][j]=dp[i-1][j-1]+1;
            if(str[i]!=nstr[j])//不相等,dp[i][j]等于上方和左方dp值得最大值
                dp[i][j]=dp[i-1][j]>dp[i][j-1]?dp[i-1][j]:dp[i][j-1];
        }
		
		cout<<n-dp[n][n]<<endl;
		return 0;
}

滚动数组

滚动数组的作用在于优化空间,主要应用在递推或动态规划中(如01背包问题)。因为DP题目是一个自底向上的扩展过程,我们常常需要用到的是连续的解,前面的解往往可以舍去。所以用滚动数组优化是很有效的。利用滚动数组的话在N很大的情况下可以达到压缩存储的作用。

例:斐波那契数列:

一般代码

int fib(int n)  
{  
    Fib[0] = 0;  
    Fib[1] = 1;  
    Fib[2] = 1;  
    for(int i = 3; i <= n; ++i)  
        Fib[i] = Fib[i - 1] + Fib[i - 2];  
    return Fib[n];  
} 

应用滚动数组

int fib(int n)  
{  
    Fib[1] = 0;   
    Fib[2] = 1;  
    for(int i = 2; i <= n; ++i)  
    {  
        Fib[0] = Fib[1];   
        Fib[1] = Fib[2];  
        Fib[2] = Fib[0] + Fib[1];  
    }  
    return Fib[2];  
} 

对于本题,用行数以0  1  0  1的滚动方式,滚动表达式为i%2和(i-1)%2 ,求余滚动

#include <iostream>
#include <cstring>
using namespace std;

#define maxn 5005
char str[maxn];//输入的字符串
char nstr[maxn];//输入的字符串的逆序列
int dp[2][maxn];//定义动态二维数组并初始化

int main()
{
    int n;//输入的字符串长度
    cin>>n;
		
    dp[0][0]=0;
    memset(dp,0,sizeof(dp));
	
    int i,j;
    for(i=1,j=n;i<=n&&j>=1;i++,j--)
    {
        cin>>str[i];
        nstr[j]=str[i];//给逆序列赋值
    }
	
    for(i=1;i<=n;i++)
        for(j=1;j<=n;j++)
        {
            if(str[i]==nstr[j])//如果字符相等,dp[i][j]等于左上值加1
                dp[i%2][j]=dp[(i-1)%2][j-1]+1;
            if(str[i]!=nstr[j])//不相等,dp[i][j]等于上方和左方dp值得最大值
                dp[i%2][j]=dp[(i-1)%2][j]>dp[i%2][j-1]?dp[(i-1)%2][j]:dp[i%2][j-1];
        }
		
		cout<<n-dp[n%2][n]<<endl;
		return 0;
}










  • 0
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值