Farmer John has gone to town to buy some farm supplies. Being a very efficient man, he always pays for his goods in such a way that the smallest number of coins changes hands, i.e., the number of coins he uses to pay plus the number of coins he receives in change is minimized. Help him to determine what this minimum number is.
FJ wants to buy T (1 ≤ T ≤ 10,000) cents of supplies. The currency system has N (1 ≤ N ≤ 100) different coins, with values V1, V2, ..., VN (1 ≤ Vi ≤ 120). Farmer John is carrying C1 coins of value V1, C2 coins of value V2, ...., and CN coins of value VN (0 ≤ Ci ≤ 10,000). The shopkeeper has an unlimited supply of all the coins, and always makes change in the most efficient manner (although Farmer John must be sure to pay in a way that makes it possible to make the correct change).
Input
Line 2: N space-separated integers, respectively V 1, V 2, ..., VN coins ( V 1, ... VN)
Line 3: N space-separated integers, respectively C 1, C 2, ..., CN
Output
Sample Input
3 70 5 25 50 5 2 1
Sample Output
3
Hint
下面是我自己写的代码从状态0出发看能到达哪些状态,最后把所有的状态种数输出就行
#include <stdio.h>
#include<algorithm>
#include<cstring>
#include<cmath>
#define M 100001
int dp[M];
inline int max(int a,int b)
{
return a>b?a:b;
}
int main()
{
//freopen("input.txt","r",stdin);
int n,m;
while(~scanf("%d%d",&n,&m)&&(m+n))
{
int a[101],c[101];
int f=0;
memset(dp,0,sizeof(dp));
for(int i=1;i<=n;i++)scanf("%d",a+i);
for(int i=1;i<=n;i++)scanf("%d",c+i);
dp[0]=1;
for(int i=1;i<=n;i++)
{
if(a[i]*c[i]>=m)
{
for(int j=a[i];j<=m;j++)
if(!dp[j]&&dp[j-a[i]])dp[j]=1;
}
else
{
int k=1;
while(k<c[i])
{
for(int j=m;j>=k*a[i];j--)
if(!dp[j]&&dp[j-k*a[i]])dp[j]=1;
c[i]-=k;
k<<=1;
}
for(int j=m;j>=c[i]*a[i];j--)
if(!dp[j]&&dp[j-c[i]*a[i]])dp[j]=1;
}
}
for(int j=1;j<=m;j++)
if(dp[j])f++;
printf("%d\n",f);
}
return 0;
}
下面是某大牛写的,把多重背包转化成完全背包,时间就优化了不少。
#include<cstdio>
#include<cstring>
#include<algorithm>
using namespace std;
const int MAX = 1e5+10;
int use[MAX]; int dp[MAX];
int a[MAX],b[MAX];
int main()
{
int n,m,ans;
while(scanf("%d %d",&n,&m)==2&&(n||m))
{
for(int i=0;i<n;i++) scanf("%d",&a[i]);
for(int i=0;i<n;i++) scanf("%d",&b[i]);
memset(dp,0,sizeof(dp)); dp[0]=1; ans=0;
for(int i=0;i<n;i++)
{
memset(use,0,sizeof(use));
for(int j=a[i];j<=m;j++)
{
if(!dp[j]&&dp[j-a[i]]&&use[j-a[i]]<b[i])
{
dp[j]=1; ans++; use[j]=use[j-a[i]]+1;
}
}
}
printf("%d\n",ans);
}
return 0;
}