LA 3905(扫描线)

Meteor

3000ms
131072KB
This problem will be judged on UVALive. Original ID:  3905
64-bit integer IO format:  %lld      Java class name:  Main
Font Size:   
Type: 
  •  
  •  
  •  
  •  
  •  
  •  
  •  
  •  
  •  
  •  
  •  
  •  
  •  
  •  
  •  
  •  
  •  
  •  
  •  
  •  
  •  
  •  
  •  
  •  
  •  
  •  
  •  
  •  
  •  
  •  
  •  
  •  
  •  
  •  
  •  
  •  
  •  
  •  
  •  
  •  
  •  
  •  
  •  
  •  
  •  
  •  
  •  
  •  
  •  
  •  
  •  
  •  
  •  
  •  
  •  
  •  
  •  
  •  
  •  
  •  
  •  
  •  
  •  
  •  
  •  
  •  
  •  
  •  
  •  
  •  
  •  
  •  
  •  
  •  
  •  
  •  
  •  
  •  
  •  
  •  
  •  
  •  
  •  
  •  
  •                    
  • [PDF Link]

    The famous Korean internet company nhn has provided an internet-based photo service which allows The famous Korean internet company users to directly take a photo of an astronomical phenomenon in space by controlling a high-performance telescope owned by nhn. A few days later, a meteoric shower, known as the biggest one in this century, is expected. nhn has announced a photo competition which awards the user who takes a photo containing as many meteors as possible by using the photo service. For this competition, nhn provides the information on the trajectories of the meteors at their web page in advance. The best way to win is to compute the moment (the time) at which the telescope can catch the maximum number of meteors.

    You have n meteors, each moving in uniform linear motion; the meteor mi moves along the trajectory pi + t×vi over time t , where t is a non-negative real value, pi is the starting point of mi and vi is the velocity of mi . The point pi = (xiyi) is represented by X -coordinate xi and Y -coordinate yi in the (XY) -plane, and the velocityvi = (aibi) is a non-zero vector with two components ai and bi in the (XY) -plane. For example, if pi = (1, 3) and vi = (-2, 5) , then the meteor mi will be at the position (0, 5.5) at time t = 0.5 because pi + t×vi = (1, 3) + 0.5×(-2, 5) = (0, 5.5) . The telescope has a rectangular frame with the lower-left corner (0, 0) and the upper-right corner (wh) . Refer to Figure 1. A meteor is said to be in the telescope frame if the meteor is in the interior of the frame (not on the boundary of the frame). For exam! ple, in Figure 1, p2p3p4 , and p5 cannot be taken by the telescope at any time because they do not pass the interior of the frame at all. You need to compute a time at which the number of meteors in the frame of the telescope is maximized, and then output the maximum number of meteors.

    \epsfbox{p3905.eps}

    Input

    Your program is to read the input from standard input. The input consists of T test cases. The number of test cases T is given in the first line of the input. Each test case starts with a line containing two integers w and h (1$ \le$wh$ \le$100, 000) , the width and height of the telescope frame, which are separated by single space. The second line contains an integer n , the number of input points (meteors), 1$ \le$n$ \le$100, 000 . Each of the next n lines contain four integers xiyiai , and bi ; (xiyi) is the starting point pi and (aibi) is the nonzero velocity vector vi of the i -th meteor; xi and yi are integer values between -200,000 and 200,000, and ai and bi are integer values between -10 and 10. Note that at least one of ai and bi is not zero. These four values are separated by single spaces. We assume that all starting points pi are distinct.

    Output

    Your program is to write to standard output. Print the maximum number of meteors which can be in the telescope frame at some moment.

    Sample Input

    2 
    4 2 
    2 
    -1 1 1 -1 
    5 2 -1 -1 
    13 6 
    7 
    3 -2 1 3 
    6 9 -2 -1 
    8 0 -1 -1 
    7 6 10 0 
    11 -2 2 1 
    -2 4 6 -1 
    3 2 -5 -1
    

    Sample Output

    1 
    2
    

    Source


    给出一个矩形,还有n个星星,星星可以看成质点,告诉你星星的坐标和速度,求矩形最多能包含多少个星星(边界上的不算),处理出每个星星在矩形里的时间区间,然后用扫描线。大白P47.


    #include <bits/stdc++.h>
    using namespace std;
    const int maxn = 1e5 + 10;
    struct Node
    {
        double x;
        bool Type;
        bool operator < (const Node & rhs) const {
            if(x == rhs.x) return Type > rhs.Type;
            return x < rhs.x;
        }
    }Item[maxn<<1];
    void Modify(int pos,int w,double v,double &L,double &R)
    {
        if(v == 0) {
            if(pos <= 0 || pos >= w) R = L-1;
            return ;
        }else if(v > 0) {
            L = max(L,-pos/v);
            R = min(R,(w-pos)/v);
        }else {
            L = max(L,(w-pos)/v);
            R = min(R,-pos/v);
        }
    }
    int main()
    {
        int T;
        scanf("%d",&T);
        for(int cas = 1; cas <= T; ++cas) {
            int w,h;scanf("%d%d",&w,&h);
            int n;scanf("%d",&n);
            int tot = 0;
            for(int i = 0; i < n; ++i) {
                int x,y,dx,dy;
                scanf("%d%d%d%d",&x,&y,&dx,&dy);
                double L = 0, R = 1e10;
                Modify(x,w,dx,L,R);
                Modify(y,h,dy,L,R);
                //printf("%.2f %.2f\n",L,R);
                if(R > L) {
                    Item[tot++] = (Node) {L,0};
                    Item[tot++] = (Node) {R,1};
                }
            }
            sort(Item,Item+tot);
            int cnt = 0,ans = 0;
            for(int i = 0; i < tot; ++i) {
                if(Item[i].Type == 0) {
                    ++cnt;
                    ans = max(ans,cnt);
                }else --cnt;
            }
            printf("%d\n",ans);
        }
        return 0;
    }
    



    • 0
      点赞
    • 0
      收藏
      觉得还不错? 一键收藏
    • 0
      评论

    “相关推荐”对你有帮助么?

    • 非常没帮助
    • 没帮助
    • 一般
    • 有帮助
    • 非常有帮助
    提交
    评论
    添加红包

    请填写红包祝福语或标题

    红包个数最小为10个

    红包金额最低5元

    当前余额3.43前往充值 >
    需支付:10.00
    成就一亿技术人!
    领取后你会自动成为博主和红包主的粉丝 规则
    hope_wisdom
    发出的红包
    实付
    使用余额支付
    点击重新获取
    扫码支付
    钱包余额 0

    抵扣说明:

    1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
    2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

    余额充值