2014_3_29_周赛 马腿上的最短路

题目描述

在一个 n*m 的棋盘上有一些点已被己方棋子占用。有一只马要从点 S(x_s, y_s) 走到点 T(x_t, y_t) ,现求一个步数最少的方案。马的每一步是这样走的:先从起点 A 向上下左右任意方向走 1 格经过点 B,再顺时针或逆时针旋转 π/4 后走 sqrt(2) 格到达点C。但这是中国象棋里的马而不是国际象棋里的 knight,即如果经过的点 B 被占用,则会发生“蹩(bié)马腿”不能这样走。只有当B 与 C 都未被占用时马才能从 A 跳到 C。
输入格式

输入包含多组数据,以 EOF 结束。

每组数据第一行包含六个整数m,n,x_s,y_s,x_t,y_t。接下来 n 行给出一个 n*m 的〇一矩阵,其中 1 表示已经被占用的格子。

0 < m, n <= 100

0 <= x_s, x_t < n

0 <= y_s, y_t < m

输出

对于每组数据,输出所求的最少步数。若不能到达(包含起点或终点被占用的情况),则输出 No solution!。
样例输入

4 4 0 0 3 2
0010
0000
0000
0001
4 4 0 0 3 2
0010
0000
0100
0001
样例输出

3
No solution!
#include <stdio.h>
#include <string.h>
#include <queue>

using namespace std;
typedef struct node {
    int x, y;
} node;

const int dx[8] = {2, 1, -1, -2, -2, -1, 1, 2};
const int dy[8] = {1, 2, 2, 1, -1, -2, -2, -1};
const int bx[8] = {1, 0, 0, -1, -1, 0, 0, 1};
const int by[8] = {0, 1, 1, 0, 0, -1, -1, 0};
bool a[105][105], vis[105][105];
int step[105][105];
int m, n, sx, sy, tx, ty;

bool check(int x, int y) {
    if (x >= 0 && x < m && y >= 0 && y < n)
        return true;
    else
        return false;
}

int bfs() {
    memset(vis, 0, sizeof (vis));
    memset(step, 0, sizeof (step));
    queue<node> q;
    node h, n;
    h.x = sx;
    h.y = sy;
    vis[sx][sy] = true;
    q.push(h);
    while (!q.empty()) {
        h = q.front();
        q.pop();
        if (h.x == tx && h.y == ty)
            return step[h.x][h.y];
        for (int i = 0; i < 8; i++) {
            n.x = h.x + dx[i];
            n.y = h.y + dy[i];
            //条件很多
            if(check(n.x, n.y) && a[h.x+bx[i]][h.y+by[i]] == 0 && !vis[n.x][n.y] && a[n.x][n.y] == 0) {
                q.push(n);
                step[n.x][n.y] = step[h.x][h.y] + 1;
                vis[n.x][n.y] = true;
            }
        }
    }
    return -1;
}

int main() {
    while (scanf("%d%d%d%d%d%d", &m ,&n, &sx, &sy, &tx, &ty) == 6) {
        for (int i = 0; i < m; i++)
            for (int j = 0; j < n; j++)
                scanf("%1d", &a[i][j]);
        if (a[sx][sy] == 1 || a[tx][ty] == 1) {
            printf("No solution!\n");
            continue;
        }
        int ans = bfs();
        if (ans == -1) {
            printf("No solution!\n");
            continue;
        }
        else
            printf("%d\n", ans);
    }
    return 0;
}

评论 1
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值