Periodic Strings |
A character string is said to have period k if it can be formed by concatenating one or more repetitions of another string of length k. For example, the string "abcabcabcabc" has period 3, since it is formed by 4 repetitions of the string "abc". It also has periods 6 (two repetitions of "abcabc") and 12 (one repetition of "abcabcabcabc").
Write a program to read a character string and determine its smallest period.
Input
The first line oif the input file will contain a single integer N indicating how many test case that your program will test followed by a blank line. Each test case will contain a single character string of up to 80 non-blank characters. Two consecutive input will separated by a blank line.
Output
An integer denoting the smallest period of the input string for each input. Two consecutive output are separated by a blank line.
Sample Input
1 HoHoHo
Sample Output
2
我自己思考的代码是:枚举法 逐个加字符串然后进子字符串长度检测
<span style="font-size:14px;">#include <iostream>
#include <string>
using namespace std;
int main(){
int T;
while(cin>>T){
while(T--){
string s;
cin>>s;
string ans = "";
for(unsigned int k,i = 0 ;i < s.length() ; i++){
ans += s.at(i);
for(k = 0;k < s.length(); k+=ans.length()) //根据步长搜索
if(ans != s.substr(k,ans.length()))break;
if(k == s.length()){
cout<<ans.length()<<endl;
if(T) cout<<endl;
break;
}
}
}
}
return 0;
}</span><span style="font-size: 17px;">
</span>
在网上大多的答案是:
#include <iostream>
#include <cstdlib>
#include <cstring>
#include <cstdio>
using namespace std;
char str[104];
int main()
{
int n;
while (~scanf("%d",&n))
while (n --) {
scanf("%s",str);
int len = strlen(str);
for (int k,i = 1 ; i <= len ; ++ i)
if (len%i == 0) {
for (k = i ; k < len ; ++ k)
if (str[k] != str[k%i])break;
if (k == len) {
printf("%d\n",i);
break;
}
}
if (n) printf("\n");
}
return 0;
}
在UVa第二行是我的代码,第一行是网上大多数的代码,按照时间来说应该快点吧,可能是数据短吧,up to 80字符