UVA - 10340 All in All

Problem E

All in All

Input: standard input

Output: standard output

Time Limit: 2 seconds

Memory Limit: 32 MB

You have devised a new encryption technique which encodes a message by inserting between its characters randomly generated strings in a clever way. Because of pending patent issues we will not discuss in detail how the strings are generated and inserted into the original message. To validate your method, however, it is necessary to write a program that checks if the message is really encoded in the final string.

Given two strings s and t, you have to decide whether s is a subsequence of t, i.e. if you can remove characters from t such that the concatenation of the remaining characters is s.

Input Specification

The input contains several testcases. Each is specified by two strings s, t of alphanumeric ASCII characters separated by whitespace. Input is terminated by EOF.

Output Specification

For each test case output, if s is a subsequence of t.

Sample Input

sequence subsequence
person compression
VERDI vivaVittorioEmanueleReDiItalia
caseDoesMatter CaseDoesMatter

Sample Output

Yes
No
Yes
No

Source: ULM Local Contest


题意:  

给你两个字符串string1、string2 如果string2字符串中删除某个字符可以等于string1,那就yes,否则就no

解题:

记录两个字符串的长度和移动,如果string1里面某个字符和string2某个字符相等就一起往后移1,否则就是string2往后移1,移到string2或者string1无法再移为止。

#include <iostream>
#include <string>
using namespace std;

int main(){
    string s,s1;
    while(cin>>s>>s1){
        unsigned int i = 0,j = 0;
        unsigned int len1 = s.length(),len2 = s1.length();
        while(i < len1 && j < len2){
            if(s.at(i) == s1.at(j))i++,j++;
            else j++;
        }
        i == len1?cout<<"Yes"<<endl:cout<<"No"<<endl;
    }
    return 0;
}



  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值