HDU - 1002 A + B Problem II

Description

I have a very simple problem for you. Given two integers A and B, your job is to calculate the Sum of A + B. 
 

Input

The first line of the input contains an integer T(1<=T<=20) which means the number of test cases. Then T lines follow, each line consists of two positive integers, A and B. Notice that the integers are very large, that means you should not process them by using 32-bit integer. You may assume the length of each integer will not exceed 1000. 
 

Output

For each test case, you should output two lines. The first line is "Case #:", # means the number of the test case. The second line is the an equation "A + B = Sum", Sum means the result of A + B. Note there are some spaces int the equation. Output a blank line between two test cases. 
 

Sample Input

    
    
2 1 2 112233445566778899 998877665544332211
 

Sample Output

    
    
Case 1: 1 + 2 = 3 Case 2: 112233445566778899 + 998877665544332211 = 1111111111111111110


题解:很明显是大数相加,但是它全部都是正数那更容易了,输入之后全部反序变成数字,两个数组个个相加,把进位记录,差不多就是这样,不过要注意换行之类的


#include <iostream>
#include <cstdio>
#include <cstring>
using namespace std;

int a[1010],b[1010],sum[1010];
int len_a,len_b,len_sum;
void changeInt(char str[],int num[],int *l){
    *l = strlen(str) - 1;
    int index = 0;
    for(int i = *l;i >= 0 ;i--){
        num[i] = str[index++] - '0';
    }
}

void add(int a[],int b[],int s[]){
    int c = 0;
    int m = 0;
    while(len_a>=m || len_b>=m){
        if(len_a<m)a[m] = 0;
        if(len_b<m)b[m] = 0;
        s[m] = a[m]+b[m]+c;
        c = s[m]/10;
        if(s[m]>9){
            s[m]=s[m]%10;
        }
        m++;
    }
    if(c) s[m] = c;
    len_sum = m - 1 + c;
}

void write(int num[],int l){
    for(int i = l;i >= 0;i--)printf("%d",num[i]);
}

int main(){
    int T;cin>>T;int count = 0;
    for(int i = 0; i < T ; i++){
        char m[1010],n[1010];
        if(count != T && count)printf("\n");
        cin>>m>>n;
        changeInt(m,a,&len_a);changeInt(n,b,&len_b);
        add(a,b,sum);
        printf("Case %d:\n",++count);
        write(a,len_a);
        printf(" + ");
        write(b,len_b);
        printf(" = ");
        write(sum,len_sum);
        printf("\n");
    }
    return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值