HDU-3333-Turing Tree(离线+哈希+树状数组|线段树)

7 篇文章 0 订阅
7 篇文章 0 订阅

Turing Tree

Time Limit: 6000/3000 MS (Java/Others) Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 5508 Accepted Submission(s): 1967

Problem Description
After inventing Turing Tree, 3xian always felt boring when solving problems about intervals, because Turing Tree could easily have the solution. As well, wily 3xian made lots of new problems about intervals. So, today, this sick thing happens again…

Now given a sequence of N numbers A1, A2, …, AN and a number of Queries(i, j) (1≤i≤j≤N). For each Query(i, j), you are to caculate the sum of distinct values in the subsequence Ai, Ai+1, …, Aj.

Input
The first line is an integer T (1 ≤ T ≤ 10), indecating the number of testcases below.
For each case, the input format will be like this:
* Line 1: N (1 ≤ N ≤ 30,000).
* Line 2: N integers A1, A2, …, AN (0 ≤ Ai ≤ 1,000,000,000).
* Line 3: Q (1 ≤ Q ≤ 100,000), the number of Queries.
* Next Q lines: each line contains 2 integers i, j representing a Query (1 ≤ i ≤ j ≤ N).

Output
For each Query, print the sum of distinct values of the specified subsequence in one line.

Sample Input
2
3
1 1 4
2
1 2
2 3
5
1 1 2 1 3
3
1 5
2 4
3 5

Sample Output
1
5
6
3
6

Author
3xian@GDUT

Source
HDOJ Monthly Contest – 2010.03.06

Recommend
lcy

题意:

求区间L,R之间不同数字的和,即相同数字只算一次

在线处理不好想,我们可以离线处理
先把所有询问铵右端点排序,然后对于每一种数字,只保留最近的出现的位置,哈希(map)处理这个位置即可,即对于每一个a[i],删掉上一次a[i]出现的,再把这次的a[i]加入
因为要计算涉及到上次a[i]时,肯定包含了这次的a[i],所以只需要保留最近的一次,大小区间包含关系(注意询问时按照区间右端点排序的)

#include<cstdio>
#include<cstring>
#include<algorithm>
#include<map>
using namespace std;
typedef long long LL;
const int maxn=2e5+5;
int a[maxn];
LL T[4*maxn],ans[maxn]; 
int opt,L,R,x,y,n,m;
map<LL,int>pre;
struct nod
{
  int l,r,id;
}b[maxn];

inline bool cmp(const nod&A,const nod&B)
{
  return A.r<B.r||(A.r==B.r&&A.l<B.l);
}

inline void add(int x,int y)
{
  for(;x<=n;x+=x&-x)T[x]+=y;
}

inline LL get(int x)
{
  LL res=0;
  for(;x;x-=x&-x)res+=T[x];
  return res;
}

int main()
{
  int t;
  scanf("%d",&t); 
  while(t--)
  {
    pre.clear();
    memset(T,0,sizeof(T));
    scanf("%d",&n);
    for(int i=1;i<=n;++i)scanf("%d",a+i);
    scanf("%d",&m);
    for(int i=1;i<=m;++i)scanf("%d%d",&b[i].l,&b[i].r),b[i].id=i;
    sort(b+1,b+1+m,cmp);
    int j=1;
    for(int i=1;i<=n;++i)
    {
      if(pre[a[i]])add(pre[a[i]],-a[i]);
      add(i,a[i]);
      while(j<=m&&b[j].r==i)
      {
        ans[b[j].id]=get(b[j].r)-get(b[j].l-1);
        j++;
      }
      if(j>m)break;
      pre[a[i]]=i;
    }
    for(int i=1;i<=m;++i)printf("%lld\n",ans[i]);
  }
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值