Steps

Description



  Steps 

One steps through integer points of the straight line. The length of a step must be nonnegative and can be by one bigger than, equal to, or by one smaller than the length of the previous step.

What is the minimum number of steps in order to get from x to y? The length of the first and the last step must be 1.

Input and Output 

Input consists of a line containing n, the number of test cases. For each test case, a line follows with two integers:  0$ \le$x$ \le$y < 231. For each test case, print a line giving the minimum number of steps to get from  x to  y.

Sample Input 

3
45 48
45 49
45 50

Sample Output 

3
3
4
 
 
解题报告

一开始找规律找错了,一开始我认为的规律是y-x的差值在不同区域的取值不同

0=0,1=1,2=2,[3,4]=3,[5,7]=4,[8,11]=5,[12,16]=6...

原来规律是

0=0,1=1,2=2,[3,4]=3,[5,6]=4,[7,9]=5,[10,12]=6,[13,16]=7...

规律是找出来了,写不好写。。。

#include<stdio.h>
int main ()
{
    int n,x,y,i,j,d,s;
    scanf("%d",&n);
    while(n--)
    {
        scanf("%d %d",&x,&y);
        d=y-x;
        if(d==0)
        printf("0\n");
    
        else
        {
            s=0;j=1;i=1;
            for(;;)
            {
            s+=j;
            if(d<=s)
            break;
            if(i%2==0)
            j++;
            i++;
            }
            printf("%d\n",i);
        }
    }
    return 0;
}


评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值