HDU 1005 解题报告

Number Sequence

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 96803    Accepted Submission(s): 23215


Problem Description
A number sequence is defined as follows:

f(1) = 1, f(2) = 1, f(n) = (A * f(n - 1) + B * f(n - 2)) mod 7.

Given A, B, and n, you are to calculate the value of f(n).
 

Input
The input consists of multiple test cases. Each test case contains 3 integers A, B and n on a single line (1 <= A, B <= 1000, 1 <= n <= 100,000,000). Three zeros signal the end of input and this test case is not to be processed.
 

Output
For each test case, print the value of f(n) on a single line.
 

Sample Input
  
  
1 1 3 1 2 10 0 0 0
 

Sample Output
  
  
2 5



分析:从1 <= n <= 100,000,000的数据量可以明显看出不能暴力解决。分析函数是对7的取余,而且函数的值f(n)仅跟f(n-1)和f(n-2)的值有关,那么必然存在单循环长度小于等于7*7的循环节(因为f(n)最多只可能有0-6这7种取值)。由于f(1)和f(2)的值是事先指定的,可能不在循环节内,所以只要从f(3)开始,最多计算50次,就可以得到循环节。


代码如下:

#include<stdio.h>
int main()
{
    int a, b, n, ans, cirLength;
    bool flag=false;
    int item[60] = {0};
    while(scanf("%d%d%d", &a, &b, &n)&&(a||b||n)){
        if(n==1||n==2){
            ans = 1;
        } else {
            item[0] = (a+b)%7;
            item[1] = (b+a*item[0])%7;
            for(int i=2; i<60; i++){
                item[i] = (a*item[i-1]+b*item[i-2])%7;
                if(item[i-1]==item[0]&&item[i]==item[1]){
                    cirLength = i-1;
                    break;
                }
            } 
            ans = item[(n-3)%cirLength];
        }
        printf("%d\n", ans);        
    }
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值