HDU 1005 (雀巢原理(狗头))

在模数的世界以零开始

Problem Description

A number sequence is defined as follows:

f(1) = 1, f(2) = 1, f(n) = (A * f(n - 1) + B * f(n - 2)) mod 7.

Given A, B, and n, you are to calculate the value of f(n).

Input

The input consists of multiple test cases. Each test case contains 3 integers A, B and n on a single line (1 <= A, B <= 1000, 1 <= n <= 100,000,000). Three zeros signal the end of input and this test case is not to be processed.

Output

For each test case, print the value of f(n) on a single line.

Sample Input

1 1 3
1 2 10
0 0 0

Sample Output

2
5

错误分析。。好丢人。还好我人气低哈哈。
这道题很自然的想到了鸽巢原理, 即肯定存在循环,但是我找循环的方式也也也太难看了吧。
其实每一个数据都是由前两个连续的序列构成的,如果存在两个连续相等的序列,那么循环从这里开始, 两个连续的序列最多有49 种, 即前50个元素一定存在循环
~

第一份代码是自己虎头虎脑写的,这样的代码太难看了, 存在 很多边界问题, 这样我是不能忍受的, 第二份才是简洁版。

#include <iostream>

using namespace std;

const int N = 100;

int t[N];

int main()
{
    int a, b, n;
    
    while(cin >> a >> b >> n && (a || b || n))
    {
        t[1] =1, t[2] = 1;
        int i, j;
        bool flag = false; 
        for(i = 3;i <= n; i ++)
        {
            t[i] = (a * t[i - 1] + b * t[i - 2]) % 7;
            for(j = 2; j < i - 1; j ++)
            {
                if(t[j] == t[i] && t[j - 1] == t[i - 1])
                {
                    flag = true;
                    break;
                }
            }
            if(flag) break;
        }
        //cout << (n - j) % (i - j) + j << endl;
        if(flag) cout << t[(n - j - 1) % (i - j) + j + 1] << endl;
        else cout << t[n] << endl;
    }
    return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值