Max Sum Plus Plus最大m段子段和

Now I think you have got an AC in Ignatius.L's "Max Sum" problem. To be a brave ACMer, we always challenge ourselves to more difficult problems. Now you are faced with a more difficult problem. 

Given a consecutive number sequence S 1, S 2, S 3, S 4 ... S x, ... S n (1 ≤ x ≤ n ≤ 1,000,000, -32768 ≤ S x ≤ 32767). We define a function sum(i, j) = S i + ... + S j (1 ≤ i ≤ j ≤ n). 

Now given an integer m (m > 0), your task is to find m pairs of i and j which make sum(i 1, j 1) + sum(i 2, j 2) + sum(i 3, j 3) + ... + sum(i m, j m) maximal (i x ≤ iy ≤ j x or i x ≤ j y ≤ j x is not allowed). 

But I`m lazy, I don't want to write a special-judge module, so you don't have to output m pairs of i and j, just output the maximal summation of sum(i x, j x)(1 ≤ x ≤ m) instead. ^_^ 

Input

Each test case will begin with two integers m and n, followed by n integers S 1, S2, S 3 ... S n
Process to the end of file. 

Output

Output the maximal summation described above in one line. 

Sample Input

1 3 1 2 3
2 6 -1 4 -2 3 -2 3

Sample Output

6
8


        
  

Hint

Huge input, scanf and dynamic programming is recommended.

 

题意:最大m段子段和且每个子段都不能重叠,一开始写的是直接是二维数组记录分前i组以j为结尾,直接内存就超了然后用滚动数组就开始超时,然后看了下题解晓得又开了一个数组来记录上一次的时候到当前位置最大的Max[i]代表的是上一次dp0~i-1的最大值,这样就保证了状态转移方程中每一次的Max数组最大的位置都是距离目前的节点一个节点的距离即Max[j-1]并不包括j-1这个点。而且是边循环边更新。

#include <bits/stdc++.h>
using namespace std;
long long int dp[1005000];
long long Max[1005000];
int a[1005000];
int main()
{
    int n,m;
    while(~scanf("%d%d",&m,&n))
    {
        memset(dp,0,sizeof(dp));
        memset(Max,0,sizeof(Max));
        for(int i=1;i<=n;i++)
            scanf("%d",&a[i]);
        long long maxx;
        for(int i=1;i<=m;i++)
        {
            maxx=-0x7fffffff;
            for(int j=i;j<=n;j++)
            {
                dp[j]=max(dp[j-1]+a[j],Max[j-1]+a[j]);
                Max[j-1]=maxx;//注意这里是j-1;
                maxx=max(maxx,dp[j]);
            }
        }
        printf("%lld\n",maxx);//直接就maxx了因为直接在循环的时候就记录下来了
    }

}

 

  • 0
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值