poj3268

One cow from each of N farms (1 ≤ N ≤ 1000) conveniently numbered 1…N is going to attend the big cow party to be held at farm #X (1 ≤ X ≤ N). A total of M (1 ≤ M ≤ 100,000) unidirectional (one-way roads connects pairs of farms; road i requires Ti (1 ≤ Ti ≤ 100) units of time to traverse.
Each cow must walk to the party and, when the party is over, return to her farm. Each cow is lazy and thus picks an optimal route with the shortest time. A cow’s return route might be different from her original route to the party since roads are one-way.
Of all the cows, what is the longest amount of time a cow must spend walking to the party and back?
Input
Line 1: Three space-separated integers, respectively: N, M, and X
Lines 2… M+1: Line i+1 describes road i with three space-separated integers: Ai, Bi, and Ti. The described road runs from farm Ai to farm Bi, requiring Ti time units to traverse.
Output
Line 1: One integer: the maximum of time any one cow must walk.
Sample Input
4 8 2
1 2 4
1 3 2
1 4 7
2 1 1
2 3 5
3 1 2
3 4 4
4 2 3
Sample Output
10
Hint
Cow 4 proceeds directly to the party (3 units) and returns via farms 1 and 3 (7 units), for a total of 10 time units.

Dijkstra算法变形求最短路径中的最大值 而且是单向图,并且最短路径是一去一回,这个题搞得我头都要炸 一直超时,应该先打好表在直接找就好了。每次都是到X这个点(有进有出)不如就全部看成从X到所有的点的最短路径,算回去的路的时候把单向图转置一下就好了
来和回的最短路径分别存到两个数组然后直接暴力。

#include <algorithm>
#include <iostream>
#include<string.h>
#include <stdio.h>
#include<cmath>
using namespace std;
int dp[19009],a[4000][1009],b[4000],n,a1[4000],a2[4000],x;

//vector<int>b;
void roda(int *b)
{
        memset(dp,0,sizeof(dp));
        for(int j=1; j<=n; j++)
            b[j]=a[x][j];
        b[x]=0;
        dp[x]=1;
        for(int j=1; j<n; j++)
        {
            int maxx=0x3f3f3f3f,u=-1;
            for(int k=1; k<=n; k++)
            {
                if(maxx>b[k]&&!dp[k])
                {
                    maxx=b[k];
                    u=k;
                }
            }
            if(u==-1)
                break;
            dp[u]=1;
            for(int o=1; o<=n; o++)
            {
                if(b[o]>b[u]+a[u][o]&&o!=x)
                    b[o]=b[u]+a[u][o];
            }
        }
}
void tran()
{
    for(int i=1;i<=n;i++)
        for(int j=1;j<i;j++)
        {
            swap(a[i][j],a[j][i]);
        }
}
int main()
{
    int m,s,flag=0,g,h,j;
    while(~scanf("%d%d%d",&n,&m,&x))
    {
        memset(a,0x3f3f3f3f,sizeof(a));
        for(int i=0; i<m; i++)
        {
            scanf("%d%d%d",&g,&h,&j);
            a[g][h]=j;
        }
        roda(a1);
        tran();
        roda(a2);
        int maxx=-1;
        for(int i=1; i<=n; i++)
                maxx=max(a1[i]+a2[i],maxx);
        cout<<maxx<<endl;

    }

}
  • 0
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值