八数码问题——HDU 1043

对应杭电题目: 点击打开链接


The 15-puzzle has been around for over 100 years; even if you don't know it by that name, you've seen it. It is constructed with 15 sliding tiles, each with a number from 1 to 15 on it, and all packed into a 4 by 4 frame with one tile missing. Let's call the missing tile 'x'; the object of the puzzle is to arrange the tiles so that they are ordered as:
 1  2  3  4
 5  6  7  8
 9 10 11 12
13 14 15  x

where the only legal operation is to exchange 'x' with one of the tiles with which it shares an edge. As an example, the following sequence of moves solves a slightly scrambled puzzle:
 1  2  3  4     1  2  3  4     1  2  3  4     1  2  3  4
 5  6  7  8     5  6  7  8     5  6  7  8     5  6  7  8
 9  x 10 12     9 10  x 12     9 10 11 12     9 10 11 12
13 14 11 15    13 14 11 15    13 14  x 15    13 14 15  x
            r->            d->            r->

The letters in the previous row indicate which neighbor of the 'x' tile is swapped with the 'x' tile at each step; legal values are 'r','l','u' and 'd', for right, left, up, and down, respectively.

Not all puzzles can be solved; in 1870, a man named Sam Loyd was famous for distributing an unsolvable version of the puzzle, and
frustrating many people. In fact, all you have to do to make a regular puzzle into an unsolvable one is to swap two tiles (not counting the missing 'x' tile, of course).

In this problem, you will write a program for solving the less well-known 8-puzzle, composed of tiles on a three by three
arrangement.
 

Input

You will receive, several descriptions of configuration of the 8 puzzle. One description is just a list of the tiles in their initial positions, with the rows listed from top to bottom, and the tiles listed from left to right within a row, where the tiles are represented by numbers 1 to 8, plus 'x'. For example, this puzzle

1 2 3
x 4 6
7 5 8

is described by this list:

1 2 3 x 4 6 7 5 8
 

Output

You will print to standard output either the word ``unsolvable'', if the puzzle has no solution, or a string consisting entirely of the letters 'r', 'l', 'u' and 'd' that describes a series of moves that produce a solution. The string should include no spaces and start at the beginning of the line. Do not print a blank line between cases.
 

Sample Input

    
    
2 3 4 1 5 x 7 6 8
 

Sample Output

    
    
ullddrurdllurdruldr
康拓展开判重,反向BFS
#include<cstdio>
#include<cstdlib>
#include<cmath>
#include<map>
#include<queue>
#include<stack>
#include<vector>
#include<algorithm>
#include<cstring>
#include<string>
#include<iostream>
const int MAXN=500000+10;
const int MAXNHASH=500000+10;
using namespace std;
typedef int State[9];
State st[MAXN];
int goal[9];
int vis[370000];
int fact[9];
int fa[MAXN];
int dir[MAXN];
int codestart,codeend;
const int dx[]={-1,1,0,0};
const int dy[]={0,0,-1,1};
char cal[5]="durl";

void init_lookup_table()
{
	fact[0]=1;
	for(int i=1; i<9; i++){
		fact[i]=fact[i-1]*i;
	}
}

int Code(State &s)
{
	int code=0;
	for(int i=0; i<9; i++){
		int cnt=0;
		for(int j=i+1; j<9; j++){
			if(s[j]<s[i]) cnt++; 
		}
		code+=fact[8-i]*cnt;
	}
	return code;
}

void bfs()
{
	memset(fa,0,sizeof(fa));
	memset(vis,0,sizeof(vis));
	int front=1, rear=2;
	while(front<rear)
	{
		//cout<<front<<endl;
		State& s=st[front];
		//if(memcmp(goal, s, sizeof(s))==0) return front;
		int z;
		for(z=0; z<9; z++) if(!s[z]) break;
		int x=z/3, y=z%3;
		for(int i=0; i<4; i++){
			int newx=x+dx[i];
			int newy=y+dy[i];
			int newz=newx*3+newy;
			if(newx>=0 && newx<3 && newy>=0 && newy<3){
				State&t =st[rear];
				memcpy(t,s,sizeof(s));
				t[newz]=s[z];
				t[z]=s[newz];
				int code=Code(t);
				int code1=Code(s);
				if(!vis[code]){
					vis[code]=1;
					fa[code]=code1;
					dir[code]=i;
					rear++;
				}
			}
		}
		front++;
	}
}

void print(int num)
{
	if(num!=codeend){
		cout<<cal[dir[num]];
		print(fa[num]);
	}
}

int main()
{
	//freopen("in.txt","r",stdin);
	init_lookup_table();
	char ch;
	for(int i=0; i<8; i++) st[1][i]=i+1;
	st[1][8]=0;
	codeend=Code(st[1]);
	vis[codeend]=1;
	bfs();
	while(cin>>ch)
	{
		if(ch=='x') goal[0]=ch-120;
		else goal[0]=ch-'0';
		for(int i=1; i<9; i++){
			cin>>ch;
			if(ch=='x') goal[i]=ch-120;
			else goal[i]=ch-'0';
		}
		codestart=Code(goal);
		if(vis[codestart]){
			print(codestart);
			cout<<endl;
		}
		else cout<<"unsolvable"<<endl;
	}
	return 0;
}


  • 0
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值