树状数组或线段树——POJ 2886

对应POJ题目:点击打开链接

Who Gets the Most Candies?Time Limit:5000MS    Memory Limit:131072KB    64bit IO Format:%I64d & %I64u

Description

N children are sitting in a circle to play a game.

The children are numbered from 1 to N in clockwise order. Each of them has a card with a non-zero integer on it in his/her hand. The game starts from the K-th child, who tells all the others the integer on his card and jumps out of the circle. The integer on his card tells the next child to jump out. Let A denote the integer. If A is positive, the next child will be the A-th child to the left. If A is negative, the next child will be the (A)-th child to the right.

The game lasts until all children have jumped out of the circle. During the game, the p-th child jumping out will get F(p) candies where F(p) is the number of positive integers that perfectly divide p. Who gets the most candies?

Input

There are several test cases in the input. Each test case starts with two integers N (0 < N ≤ 500,000) and K (1 ≤ KN) on the first line. The next N lines contains the names of the children (consisting of at most 10 letters) and the integers (non-zero with magnitudes within 108) on their cards in increasing order of the children’s numbers, a name and an integer separated by a single space in a line with no leading or trailing spaces.

Output

Output one line for each test case containing the name of the luckiest child and the number of candies he/she gets. If ties occur, always choose the child who jumps out of the circle first.

Sample Input

4 2
Tom 2
Jack 4
Mary -1
Sam 1

Sample Output

Sam 3

N 个小孩围成一圈,他们被顺时针编号为 1 到 N。每个小孩手中有一个卡片,上面有一个非 0 的数字,游戏从第 K 个小孩开始,他告诉其他小孩他卡片上的数字并离开这个圈,他卡片上的数字 A 表明了下一个离开的小孩,如果 A 是大于 0 的,则下个离开的是左手边第 A 个,如果是小于 0 的,则是右手边的第 -A 个小孩。游戏将直到所有小孩都离开,在游戏中,第 p 个离开的小孩将得到 F(p) 个糖果,F(p) 是 p 的约数的个数,问谁将得到最多的糖果。输出最幸运的小孩的名字和他可以得到的糖果。

//以上的翻译是从网上找的

树状数组:

#include<cstdio>
#include<cstdlib>
#include<cmath>
#include<map>
#include<queue>
#include<stack>
#include<vector>
#include<algorithm>
#include<cstring>
#include<string>
#include<iostream>
const int MAXN=500000+10;
using namespace std;
int c[MAXN];
const int ap[] = {1,2,4,6,12,24,36,48,60,120,180,240,360,720,840,1260,1680,2520,5040,7560,10080,15120,20160,25200,27720,45360,50400,55440,83160,110880,166320,221760,277200,332640,498960,554400};  
const int f[] = {1,2,3,4,6,8,9,10,12,16,18,20,24,30,32,36,40,48,60,64,72,80,84,90,96,100,108,120,128,144,160,168,180,192,200,216};  
int n,k;

struct People
{
	char name[15];
	int card;
}p[MAXN];

int lowbit(int x)
{
	return x&(-x);
}

int sum(int x)
{
	int res=0;
	while(x>0)
	{
		res+=c[x];
		x-=lowbit(x);
	}
	return res;
}

void updata(int x, int val)
{
	while(x<=MAXN)
	{
		c[x]+=val;
		x+=lowbit(x);
	}
}

int twosearch(int num)
{
	int left=1,right=n;
	while(left<right)
	{
		int mid=left+(right-left)/2;
		int s=sum(mid);
		if(s>=num) right=mid;
		else left=mid+1;
	}
	return left;
}

int main()
{
	//freopen("in.txt","r",stdin);
	while(scanf("%d%d", &n,&k)==2)
	{
		memset(c,0,sizeof(c));
		int cnt=0;
		while(ap[cnt]<=n) cnt++;
		cnt--;
		int most=ap[cnt];
		
		int i,j;
		for(i=1; i<=n; i++){
			scanf("%s%d", p[i].name, &p[i].card);
			updata(i,1);
		}

		int pos=k;
		int len=n;
		for(i=1; i<=most; i++){
			updata(pos,-1);
			if(i==most) break;
			len--;
			if(p[pos].card>0) k=((k+p[pos].card-2)%len+len)%len+1;
			else k=((k+p[pos].card-1)%len+len)%len+1;
			pos=twosearch(k);
		}

		printf("%s %d\n", p[pos].name, f[cnt]);
	}
	return 0;
}

线段树:

#include<cstdio>
#include<cstdlib>
#include<cmath>
#include<map>
#include<queue>
#include<stack>
#include<vector>
#include<algorithm>
#include<cstring>
#include<string>
#include<iostream>
const int MAXN=500000+10;
using namespace std;
int c[MAXN];
const int ap[] = {1,2,4,6,12,24,36,48,60,120,180,240,360,720,840,1260,1680,2520,5040,7560,10080,15120,20160,25200,27720,45360,50400,55440,83160,110880,166320,221760,277200,332640,498960,554400};  
const int f[] = {1,2,3,4,6,8,9,10,12,16,18,20,24,30,32,36,40,48,60,64,72,80,84,90,96,100,108,120,128,144,160,168,180,192,200,216};  
int n,k;

struct People
{
	char name[15];
	int card;
}p[MAXN];

int tree[MAXN*4];

void buildtree(int left, int right, int pos)
{
	if(left==right){
		tree[pos]=1;
		return;
	}
	int mid=(left+right)>>1;
	buildtree(left, mid, pos<<1);
	buildtree(mid+1, right, pos<<1|1);
	tree[pos]=tree[pos<<1]+tree[pos<<1|1];
}

int updata(int left, int right, int pos, int x)
{
	tree[pos]--;
	if(left==right) return left;
	int mid=(left+right)>>1;
	if(tree[pos<<1]>=x) updata(left, mid, pos<<1, x);
	else updata(mid+1, right, pos<<1|1, x-tree[pos<<1]);
}

int main()
{
	//freopen("in.txt","r",stdin);
	while(scanf("%d%d", &n,&k)==2)
	{
		memset(c,0,sizeof(c));
		int cnt=0;
		while(ap[cnt]<=n) cnt++;
		cnt--;
		int most=ap[cnt];
		
		int i,j;
		for(i=1; i<=n; i++){
			scanf("%s%d", p[i].name, &p[i].card);
		}

		buildtree(1,n,1);
		/*for(i=1; i<=30; i++){
			cout<<"tree["<<i<<"].val="<<tree[i]<<endl;
		}*/

		int pos=0;
		p[pos].card=0;
		int len=n;
		for(i=1; i<=most; i++){
			if(p[pos].card>0) k=((k+p[pos].card-2)%len+len)%len+1;
			else k=((k+p[pos].card-1)%len+len)%len+1;
			pos=updata(1, n, 1, k);
			//cout<<k<<endl;
			//cout<<pos<<endl<<endl;
			len--;
		}

		printf("%s %d\n", p[pos].name, f[cnt]);
	}
	return 0;
}



  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值