线段树计算逆序数——HDU 1394

Minimum Inversion Number

Time Limit: 1000MS Memory Limit: 32768KB 64bit IO Format: %I64d & %I64u

[]   [Go Back]   [Status]  

Description

The inversion number of a given number sequence a1, a2, ..., an is the number of pairs (ai, aj) that satisfy i < j and ai > aj.       

For a given sequence of numbers a1, a2, ..., an, if we move the first m >= 0 numbers to the end of the seqence, we will obtain another sequence. There are totally n such sequences as the following:       

a1, a2, ..., an-1, an (where m = 0 - the initial seqence)       
a2, a3, ..., an, a1 (where m = 1)       
a3, a4, ..., an, a1, a2 (where m = 2)       
...       
an, a1, a2, ..., an-1 (where m = n-1)       

You are asked to write a program to find the minimum inversion number out of the above sequences.       
              

Input

The input consists of a number of test cases. Each case consists of two lines: the first line contains a positive integer n (n <= 5000); the next line contains a permutation of the n integers from 0 to n-1.       
              

Output

For each case, output the minimum inversion number on a single line.       
              

Sample Input

    
    
10 1 3 6 9 0 8 5 7 4 2
              

Sample Output

    
    
16
        

题意:有0~n-1数字组成的序列,然后进行这样的操作,每次将最前面一个元素放到最后面去会得到一个序列,每得到一个序列都可得出该序列的逆序数(如果一对数的前后位置与大小顺序相反,即前面的数大于后面的数,那么它们就称为一个逆序。一个排列中逆序的总数就称为这个排列的逆序数)。要求求出最小的逆序数。

 

可暴力,可线段树优化;

#include<cstdio>
#include<cstdlib>
#include<cmath>
#include<map>
#include<queue>
#include<stack>
#include<vector>
#include<algorithm>
#include<cstring>
#include<string>
#include<iostream>
const int MAXN=5000+10;
using namespace std;

int tree[MAXN*4];
int sum;
int a[MAXN];

void update(int left, int right, int rt, int val)
{
	if(left==right){
		tree[rt]=1;
		return;
	}
	int mid=(left+right)>>1;
	if(val<=mid) update(left, mid, rt<<1, val);
	else update(mid+1, right, rt<<1|1, val);
	tree[rt]=tree[rt<<1]+tree[rt<<1|1];
}

void query(int left, int right, int rt, int l, int r)
{
	if(l<=left && right<=r){
		sum+=tree[rt];
		return;
	}
	int mid=(left+right)>>1;
	if(r<=mid) query(left, mid, rt<<1, l, r);
	else if(l>mid) query(mid+1, right, rt<<1|1, l, r);
	else{
		query(left, mid, rt<<1, l, r);	
		query(mid+1, right, rt<<1|1, l, r);
	}
}

int main()
{
	//freopen("in.txt","r",stdin);
	int n;
	while(scanf("%d", &n)==1)
	{
		memset(tree,0,sizeof(tree));
		int i,j;
		sum=0;
		for(i=1; i<=n; i++){
			scanf("%d", &a[i]);
			j=a[i]+1;
			query(1,n,1,j,n);	
			update(1,n,1,j);
		}
		int ans=sum;
		for(i=1; i<n; i++){
			sum=sum-a[i]+n-a[i]-1;
			if(sum<ans) ans=sum;
		}
		printf("%d\n", ans);
	}
	return 0;
}


 

  • 0
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值