有趣的逆序数——HDU1394

对应HDU题目:点击打开链接

Minimum Inversion Number

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 11466    Accepted Submission(s): 7049


Problem Description
The inversion number of a given number sequence a1, a2, ..., an is the number of pairs (ai, aj) that satisfy i < j and ai > aj.

For a given sequence of numbers a1, a2, ..., an, if we move the first m >= 0 numbers to the end of the seqence, we will obtain another sequence. There are totally n such sequences as the following:

a1, a2, ..., an-1, an (where m = 0 - the initial seqence)
a2, a3, ..., an, a1 (where m = 1)
a3, a4, ..., an, a1, a2 (where m = 2)
...
an, a1, a2, ..., an-1 (where m = n-1)

You are asked to write a program to find the minimum inversion number out of the above sequences.
 

Input
The input consists of a number of test cases. Each case consists of two lines: the first line contains a positive integer n (n <= 5000); the next line contains a permutation of the n integers from 0 to n-1.
 

Output
For each case, output the minimum inversion number on a single line.
 

Sample Input
  
  
10 1 3 6 9 0 8 5 7 4 2
 

Sample Output
  
  
16
 


题意:就是给出n个数,如1,3,6,9,0,8,5,7,4,2这n=10个数,把第一个数放到最後面,其他不变,求该数列的逆序数的个数;之后又把第一个数放到最後面,。。。。

这样进行n-1次,求逆序数最小的序列的逆序数有多少个?

思路:只需要求出一个序列的逆序数,其他的可以根据sum=sum-a[i]+n-a[i]-1   得出;i为1~n-1,a[1]表示第二个数;求逆序数这里采用边输入边计算的方法,就比如这个例子:

输入1,就看2~9的范围已经输入了多少个数,这里是0个

输入3,就看4~9的范围已经输入了多少个数,这里是0个

.。。。

输入0,就看1~9的范围已经输入了多少个数,这里有1,3,6,9这4个

很明显,用线段数或树状数组能轻松解决;

还有就是归并排序能更快地解决!


数状数组:

#include<cstdio>
#include<cstdlib>
#include<cmath>
#include<map>
#include<queue>
#include<stack>
#include<vector>
#include<algorithm>
#include<cstring>
#include<string>
#include<iostream>
const int MAXN=5000+10;
using namespace std;
int c[MAXN];
int a[MAXN];

int lowbit(int x)
{
	return x&(-x);
}

void updata(int x, int num)
{
	while(x<=MAXN)
	{
		c[x]+=num;
		x+=lowbit(x);
	}
}

int Sum(int x)
{
	int res=0;
	while(x>0)
	{
		res+=c[x];
		x-=lowbit(x);
	}
	return res;
}

int main()
{
    //freopen("in.txt","r",stdin);
    int n;
    while(scanf("%d", &n)==1)
    {
        memset(c,0,sizeof(c));
        int i,j;
        int sum=0;
        for(i=1; i<=n; i++){
            scanf("%d", &a[i]);
            j=a[i]+1;
			sum+=Sum(n+1)-Sum(j);0
            updata(j,1);
        }
        int ans=sum;
        for(i=1; i<n; i++){
            sum=sum-a[i]+n-a[i]-1;
            if(sum<ans) ans=sum;
        }
        printf("%d\n", ans);
    }
    return 0;
}



线段数:


#include<cstdio>
#include<cstdlib>
#include<cmath>
#include<map>
#include<queue>
#include<stack>
#include<vector>
#include<algorithm>
#include<cstring>
#include<string>
#include<iostream>
const int MAXN=5000+10;
using namespace std;

int tree[MAXN*4];
int sum;
int a[MAXN];

void update(int left, int right, int rt, int val)
{
    if(left==right){
        tree[rt]=1;
        return;
    }
    int mid=(left+right)>>1;
    if(val<=mid) update(left, mid, rt<<1, val);
    else update(mid+1, right, rt<<1|1, val);
    tree[rt]=tree[rt<<1]+tree[rt<<1|1];
}

void query(int left, int right, int rt, int l, int r)
{
    if(l<=left && right<=r){
        sum+=tree[rt];
        return;
    }
    int mid=(left+right)>>1;
    if(r<=mid) query(left, mid, rt<<1, l, r);
    else if(l>mid) query(mid+1, right, rt<<1|1, l, r);
    else{
        query(left, mid, rt<<1, l, r);    
        query(mid+1, right, rt<<1|1, l, r);
    }
}

int main()
{
    //freopen("in.txt","r",stdin);
    int n;
    while(scanf("%d", &n)==1)
    {
        memset(tree,0,sizeof(tree));
        int i,j;
        sum=0;
        for(i=1; i<=n; i++){
            scanf("%d", &a[i]);
            j=a[i]+1;
            query(1,n,1,j,n);    
            update(1,n,1,j);
        }
        int ans=sum;
        for(i=1; i<n; i++){
            sum=sum-a[i]+n-a[i]-1;
            if(sum<ans) ans=sum;
        }
        printf("%d\n", ans);
    }
    return 0;
}



归并排序:

#include<cstdio>
#include<cstdlib>
#include<cmath>
#include<map>
#include<queue>
#include<stack>
#include<vector>
#include<algorithm>
#include<cstring>
#include<string>
#include<iostream>
const int MAXN=5000+10;
using namespace std;
int a[MAXN];
int A[MAXN];
int t[MAXN];
int sum;

void merge_sort(int *A,int x,int y,int *t){
    if(y-x>1){
        int m=x+(y-x)/2;
        int p=x,q=m,i=x;
        merge_sort(A,x,m,t);
        merge_sort(A,m,y,t);
        while(p<m || q<y){
            if(q>=y || (p<m && A[p]<=A[q]))
                t[i++]=A[p++];
            else{
                t[i++]=A[q++];
                sum+=m-p;
            }
        }
        for(i=x;i<y;i++){
            A[i]=t[i];
        }
    }
}

int main()
{
    //freopen("in.txt","r",stdin);
    int n;
    while(scanf("%d", &n)==1)
    {
        int i,j;
        sum=0;
        for(i=1; i<=n; i++){
            scanf("%d", &a[i]);
        }
        memcpy(A,a,sizeof(a));
        merge_sort(a,1,n+1,t);
        int ans=sum;
        for(i=1; i<n; i++){
            sum=sum-A[i]+n-A[i]-1;
            if(sum<ans) ans=sum;
        }
        printf("%d\n", ans);
    }
    return 0;
}






  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值