a的n次幂 —— POJ 3100 Root of the Problem

对应POJ题目:点击打开链接

Root of the Problem
Time Limit: 1000MS Memory Limit: 65536K
Total Submissions: 11962 Accepted: 6409

Description

Given positive integers B and N, find an integer A such that AN is as close as possible to B. (The result A is an approximation to the Nth root of B.) Note that AN may be less than, equal to, or greater than B.

Input

The input consists of one or more pairs of values for B and N. Each pair appears on a single line, delimited by a single space. A line specifying the value zero for both B and N marks the end of the input. The value of B will be in the range 1 to 1,000,000 (inclusive), and the value of N will be in the range 1 to 9 (inclusive).

Output

For each pair B and N in the input, output A as defined above on a line by itself.

Sample Input

4 3
5 3
27 3
750 5
1000 5
2000 5
3000 5
1000000 5
0 0

Sample Output

1
2
3
4
4
4
5
16

题意:

给出B, N (B在[1, 1000000]内, N在[1, 9]内);求一个整数A, 使A^N最接近B。


思路:

从小到大枚举A,或者对[1, 1000000]进行二分,数据比较小。


#include <stdio.h>
#include <stdlib.h>
#include <string.h>
#include <math.h>
#define Min 1
#define Max 1000000
int b, n;

double My_pow(int a, int n)
{
	if(1 == n) return (double)a;
	if(n & 1){
		double ans;
		ans = My_pow(a, (n - 1) / 2);
		return ans * ans * a;
	}
	else{
		double ans;
		ans = My_pow(a, n / 2);
		return ans * ans;
	}
}

void Bsearch(int l, int r, int *x, int *y)
{
	while(l <= r){
		int mid = ((l + r) >> 1);
		double s = My_pow(mid, n);
		if(s == (double)b){
			*x = *y = mid;
			break;
		}
		else if(s > (double)b){
			*y = mid;
			r = mid - 1;
		}
		else{
			*x = mid;
			l = mid + 1;
		}
	}
}

int main()
{
#if 0
	freopen("in.txt","r",stdin);
#endif
	while(scanf("%d%d", &b, &n), b && n){
		int x = 1, y = 1;
		Bsearch(Min, Max, &x, &y);
		if(abs(My_pow(x, n) - b) < abs(My_pow(y, n) - b))
			printf("%d\n", x);
		else
			printf("%d\n", y);
	}
	return 0;
}










  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值