G.MaxArea(SCUT 2014 春季选拔第一场 补充)

G.MaxArea

1000ms   /   65536KB   /   C, C++ or JAVA

Editor: dovegx

Description

Cellsof a matrix are called adjacent if they share an edge. A matrix of zeroes andones is called a chess matrix if there are no two adjacent cells that share thesame value. Hence, in a chess matrix the zeroes and ones have to alternate inthe same way the colors alternate on a chessboard.
You are given a matrix board with n rows and m columns that represents arectangular grid of cells, with a 0 or a 1 in each cell. Each character of eachelement of board will be either '0' or '1'. In this grid we selected somerectangular subgrid that is a chess matrix. Calculate the largest possible areaof the selected subgrid.

Input Description

Input contains multiple test cases.
For each case the first line contains two integer n, m. ( 1 <= n, m <=300 )
The next n lines each contains m integers, either ‘0’ or ‘1’.

Output Description

For each case output one integer means thelargest possible area of the selected subgrid that is a chess matrix.

Sample Input

3 3

0 1 1

1 0 1

0 0 0

2 4

0 1 0 1

1 0 1 0

Sample Output

4

8


题解:先处理每个点向右的合法长度,然后枚举左上角,向下撸就行了

#include <iostream>
#include <cstring>
#include <cstdio>
#include <cmath>
#include <algorithm>
#include <vector>
#include <map>
#include <string>
#include <set>
#include <ctime>
#include <queue>
#include <numeric>
#include <list>
#include <functional>

using namespace std; 

#define eps 1e-8
#define LL long long
#define ULL unsigned long long
#define mod 1000000007
#define MP make_pair
#define PII pair<int, int>
#define INF 0x3f3f3f3f


int a[305][305];
int col[305][305], row[305][305];
int main() 
{
	int n, m;
	while (~scanf("%d%d", &n, &m))
	{
		for (int i = 0; i < n; ++i)
		{
			for (int j = 0; j < m; ++j)
			{
				scanf("%d", &a[i][j]);
			}
		}
		for (int k = 0; k < n; ++k)  // 枚举合法长度
		{ 
			for (int i = 0; i < m; ++i)
			{
				int tmp = 1;
				for (int j = i + 1; j < m; ++j)
				{
					if (a[k][j] != a[k][j-1])
					{
						tmp++;
					}
					else break; //这个break一开始不小心删掉了,害我找了一晚上
				}
				row[k][i] = tmp; //另开数组保存
			}
		}
		int ans = 0;
		for (int k = 0; k < m; ++k)
		{
			for (int i = 0; i < n; ++i)
			{
				//int tmp = 1;
				int minn = row[i][k];
				ans = max(minn, ans);  //要注意先比较,因为有可能 n = 1,然后下面for就不会继续。
				for (int j = i + 1; j < n; ++j)
				{
					if (a[j][k] != a[j-1][k])
					{
						minn = min(minn, row[j][k]);
						ans = max(ans, minn*(j-i+1));
					}
					else break;
				}
				
			}
		}
		printf("%d\n", ans);
	}
	return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
资源包主要包含以下内容: ASP项目源码:每个资源包中都包含完整的ASP项目源码,这些源码采用了经典的ASP技术开发,结构清晰、注释详细,帮助用户轻松理解整个项目的逻辑和实现方式。通过这些源码,用户可以学习到ASP的基本语法、服务器端脚本编写方法、数据库操作、用户权限管理等关键技术。 数据库设计文件:为了方便用户更好地理解系统的后台逻辑,每个项目中都附带了完整的数据库设计文件。这些文件通常包括数据库结构图、数据表设计文档,以及示例数据SQL脚本。用户可以通过这些文件快速搭建项目所需的数据库环境,并了解各个数据表之间的关系和作用。 详细的开发文档:每个资源包都附有详细的开发文档,文档内容包括项目背景介绍、功能模块说明、系统流程图、用户界面设计以及关键代码解析等。这些文档为用户提供了深入的学习材料,使得即便是从零开始的开发者也能逐步掌握项目开发的全过程。 项目演示与使用指南:为帮助用户更好地理解和使用这些ASP项目,每个资源包中都包含项目的演示文件和使用指南。演示文件通常以视频或图文形式展示项目的主要功能和操作流程,使用指南则详细说明了如何配置开发环境、部署项目以及常见问题的解决方法。 毕业设计参考:对于正在准备毕业设计的学生来说,这些资源包是绝佳的参考材料。每个项目不仅功能完善、结构清晰,还符合常见的毕业设计要求和标准。通过这些项目,学生可以学习到如何从零开始构建一个完整的Web系统,并积累丰富的项目经验。
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值