UVA 10780 Again Prime? No time

Again Prime? No time.
Input: standard input
Output: standard output
Time Limit: 1 second


The problem statement is very easy. Given a number n you have to determine the largest power of m, not necessarily prime, that dividesn!.

 

Input

 

The input file consists of several test cases. The first line in the file is the number of cases to handle. The following lines are the cases each of which contains two integers m (1<m<5000) and n (0<n<10000). The integers are separated by an space. There will be no invalid cases given and there are not more that 500 test cases.

Output

 

For each case in the input, print the case number and result in separate lines. The result is either an integer if m divides n! or a line "Impossible to divide" (without the quotes). Check the sample input and output format.

 

Sample Input

2
2 10
2 100

Sample Output

Case 1:
8
Case 2:
97

 

#include <iostream>
#include <algorithm>
#define INF 1000000000
using namespace std;
//此题注意要分解质因数
int fun (int m, int n)
{
    int a = 0;
    for(int i=m; i<=n; i+=m){
        int t = i;
        while (t%m == 0){
            a ++ ;
            t /= m;
        }
    }
    return a;
}
int main()
{
    int T = 0;
    cin >> T;
    for (int j=1; j<=T; j++){
        int m = 0, n = 0;
        cin >> m >> n;
        int ans = INF, i = 2;
        while (m > 1){
            if (m%i == 0){
                int t = 1;
                m /= i;
                while (m % i == 0){
                    t++;
                    m /= i;
                }
                ans = min (ans,fun(i,n)/t);
            }
            i++;
        }
        cout << "Case " << j << ":" <<endl;
        if (!ans) cout << "Impossible to divide" <<endl;
        else cout << ans << endl;
    }
    return 0;
}

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值