uva 10494(高精度)

题目:

Oooooooooooooooh!

If I could do the easy mathematics like my school days!! 

I can guarantee, that I’d not make any mistake this time!!”

Says a smart university student!!

But his teacher even smarter – “Ok! I’d assign you such projects in your software lab. Don’t be so sad.”

“Really!!” - the students feels happy. And he feels so happy that he cannot see the smile in his teacher’s face.

The Problem

The first project for the poor student was to make a calculator that can just perform the basic arithmetic operations.

But like many other university students he doesn’t like to do any project by himself. He just wants to collect programs from here and there. As you are a friend of him, he asks you to write the program. But, you are also intelligent enough to tackle this kind of people. You agreed to write only the (integer) division and mod (% in C/C++) operations for him.

input

Input is a sequence of lines. Each line will contain an input number. One or more spaces. A sign (division or mod). Again spaces. And another input number. Both the input numbers are non-negative integer. The first one may be arbitrarily long. The second number n will be in the range (0 < n < 231).

output

A line for each input, each containing an integer. See the sample input and output. Output should not contain any extra space.

sample input

110 / 100

99 % 10

2147483647 / 2147483647

2147483646 % 2147483647

sample output

1

9

1

21474836464

题解:高精度求商求余,模拟一下运算,被除数从左边第一位开始除以除数,商存到该位的答案里,对除数取模再乘10加到被除数的第二个数里,以此类推。余数就是除法进行完毕后最后被除数最后一位对除数取模就得到结果。第二个数据要用long 或long long来存,不然会WA,而且中间值也要存成long long ,不然还会WA。。。

#include <iostream>
#include <string>
#include <cstring>
#include <cstdio>
using namespace std;

const int N = 1000;
char str[N];
int  flag;
long long ans[N], s[N], n, len;

int subtract() {
	memset(ans, 0, sizeof(ans));
	long long int i, j;
	for (i = 1, j = 0; i <= 1000000000; i *= 10, j++)
		if (n / i == 0)
			break;
	if (j > len && flag == 1) {
		cout << '0' << endl;
		return j;
	}
	for (i = 0; i < len - 1; i++) {
		ans[i] = s[i] / n;
		s[i + 1] += (s[i] % n) * 10;
	}
	ans[len - 1] = s[len - 1] / n;
	for (i = 0; i < len; i++) {
		if (ans[i] != 0)
			break;
	}
	if (flag == 1) {
		if (i == len)
			cout << '0' << endl;
		else {
			for (j = i; j < len; j++)
				cout << ans[j];
			cout << endl;
		}
	}
	return j;
}

void remain(long long int j) {
	long long int i;
	if (j > len) {
		for (i = 0; i < len; i++)
			cout << s[i];
		cout << endl;
		return;
	}
	cout << s[len - 1] % n << endl;
}
int main(){
	long long int i;
	char c;
	while (~scanf("%s %c %lld", str, &c, &n)) {
		if (c == '/')
			flag = 1;
		if (c == '%')
			flag = 2;
		len = strlen(str);
		memset(s, 0, sizeof(s));
		for (i = 0; i < len; i++)
			s[i] = str[i] - '0';
		long long int j = subtract();
		if (flag == 2)
			remain(j);
		memset(str, '\0', sizeof(str));
	}
	return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值