UVA 10200 (高精度)

Euler is a well-known matematician, and, among many other things, he discovered that the formula
n
2 + n + 41 produces a prime for 0 ≤ n < 40. For n = 40, the formula produces 1681, which is 41 ∗ 41.
Even though this formula doesn’t always produce a prime, it still produces a lot of primes. It’s known
that for n ≤ 10000000, there are 47,5% of primes produced by the formula!
So, you’ll write a program that will output how many primes does the formula output for a certain
interval.
Input
Each line of input will be given two positive integer a and b such that 0 ≤ a ≤ b ≤ 10000. You must
read until the end of the file.
Output
For each pair a, b read, you must output the percentage of prime numbers produced by the formula in
this interval (a ≤ n ≤ b) rounded to two decimal digits.
Sample Input
0 39
0 40
39 40
Sample Output
100.00
97.56
50.00

打表不说,高精度什么鬼,能不能好好的了,输出加一个 1e-8 有毛线用啊,不加还不让过,第一次遇到这种高精度的体啊,被坑死了。

#include <cstdio>
#include <cstring>
#include <algorithm>
#include <queue>
#include <cmath>
using namespace std;
#define M 10010
#define LL long long

int al[M];
LL x;
bool isprime(LL x)
{
    for(LL i=2; i*i<=x; i++)
    {
        if(x % i == 0)
            return false;
    }
    return true;
}
int num = 0;
void dabiao()
{
    for(LL i=0; i<M; i++)
    {
        x = i * i + i + 41;
        if(!isprime(x))
        {
            num++;
        }
        al[i] = num;
    }
}

int main()
{
    dabiao();
    int a, b;
    double ans = 0;
    while(scanf("%d%d", &a, &b) != EOF)
    {
        if(!a)
        {
            ans = 1.0 - (double)al[b] / (double)(b+1);

        }
        else
        {
            ans = 1.0 - (double)(al[b] - al[a-1]) / (double)(b - a + 1);
        }
        ans = ans * 100.0;
        printf("%.2lf\n", ans + 1e-8);
    }

    return 0;
}
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值