Solve this equation&& Just Solve It(二分)

Solve this equation
  Time Limit:1000MS     Memory Limit:32768KB     64bit IO Format:%I64d & %I64u 
Submit Status

 

Description


Now,given the equation 8*x^4 + 7*x^3 + 2*x^2 + 3*x + 6 == Y,can you find its solution between 0 and 100;
Now please try your lucky.

 


Input


The first line of the input contains an integer T(1<=T<=100) which means the number of test cases. Then T lines follow, each line has a real number Y (fabs(Y) <= 1e10);

 


Output


For each test case, you should just output one real number(accurate up to 4 decimal places),which is the solution of the equation,or “No solution!”,if there is no solution for the equation between 0 and 100.

 


Sample Input


2
100
-4


 


Sample Output


1.6152
No solution!


 #include <iostream>
#include <cstdio>
#include <cstring>
#include <cmath>

using namespace std;

double getx(double x)
{
   double y=8*x*x*x*x + 7*x*x*x + 2*x*x + 3*x + 6;
    return y;
}
int main()
{
    int t,i;
    double l,h,y;
    scanf("%d",&t);
    for(i=0;i<t;i++)
    {
        scanf("%lf",&y);
        l=0.0;h=100.0;
        if(getx(0.0)>y||getx(100.0)<y)
        {
            printf("No solution!\n");
            continue;
        }

        double mid;
        while(fabs(getx(mid)-y)>1e-5)
        {
            mid=(h+l)/2.0;
            if(getx(mid)>y)
                h=mid-1;
                else
                l=mid+1;
            }
            printf("%.4lf\n",mid);
        }
      return 0;
    }

 

 

 

 


                                               Just Solve It
Time Limit: 1 Sec  Memory Limit: 128 MB
Submit: 23  Solved: 10
[Submit][Status][Web Board]
Description


Solve the equation:

        p*e^(-x) + q*sin(x) + r*cos(x) + s*tan(x) + t*x^2 + u = 0

        where 0 <= x <= 1.


Input


Input consists of multiple test cases and terminated by an EOF. Each test case consists of 6 integers in a single line: p, q, r, s, t and u (where 0 <= p,r <= 20 and -20 <= q,s,t <= 0).


Output


For each set of input, there should be a line containing the value of x, correct upto 4 decimal places, or the string "No solution", whichever is applicable.


Sample Input
0 0 0 0 -2 1
1 0 0 0 -1 2
1 -1 1 -1 -1 1

Sample Output
0.7071
No solution
0.7554

 

 

 

#include <iostream>
#include <cstdio>
#include <cstring>
#include <string>
#include <cmath>

using namespace std;

const double a = 1e-14;
double p,q,r,s,t,u;
double gety(double x)
{
    double y;
     y=p*exp(-x)+q*sin(x)+r*cos(x)+s*tan(x)+t*x*x+u;
    return y;
}

int main()
{

    while(scanf("%lf%lf%lf%lf%lf%lf",&p,&q,&r,&s,&t,&u)!=EOF)
    {
        double l=0.0,h=1.0;
        if(gety(l)*gety(h)<=a)
        {
            double mid;
            while(h-l>a)
            {
                mid=(h+l)/2.0;

               if(gety(mid)<0)
                  h=mid;
                else
                  l=mid;
            }
         printf("%.4lf\n",mid);
        }
        else

            printf("No solution\n");

    }
    return 0;


}

 

看着问题很简单直接二分,但是当我判断循环条件是。。。。。哇!还有这两道题看似太像了吧!!!!!!!!!!!!!
好吧!!!

 


 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值