POJ2395(最小生成树Kruskal算法)

Out of Hay
Time Limit: 1000MS Memory Limit: 65536K
Total Submissions: 11541 Accepted: 4501

Description

The cows have run out of hay, a horrible event that must be remedied immediately. Bessie intends to visit the other farms to survey their hay situation. There are N (2 <= N <= 2,000) farms (numbered 1..N); Bessie starts at Farm 1. She'll traverse some or all of the M (1 <= M <= 10,000) two-way roads whose length does not exceed 1,000,000,000 that connect the farms. Some farms may be multiply connected with different length roads. All farms are connected one way or another to Farm 1. 

Bessie is trying to decide how large a waterskin she will need. She knows that she needs one ounce of water for each unit of length of a road. Since she can get more water at each farm, she's only concerned about the length of the longest road. Of course, she plans her route between farms such that she minimizes the amount of water she must carry. 

Help Bessie know the largest amount of water she will ever have to carry: what is the length of longest road she'll have to travel between any two farms, presuming she chooses routes that minimize that number? This means, of course, that she might backtrack over a road in order to minimize the length of the longest road she'll have to traverse.

Input

* Line 1: Two space-separated integers, N and M. 

* Lines 2..1+M: Line i+1 contains three space-separated integers, A_i, B_i, and L_i, describing a road from A_i to B_i of length L_i.

Output

* Line 1: A single integer that is the length of the longest road required to be traversed.

Sample Input

3 3
1 2 23
2 3 1000
1 3 43

Sample Output

43

Hint

OUTPUT DETAILS: 

In order to reach farm 2, Bessie travels along a road of length 23. To reach farm 3, Bessie travels along a road of length 43. With capacity 43, she can travel along these roads provided that she refills her tank to maximum capacity before she starts down a road.



解题思路:
Arthur说明天组内比赛,于是赛前温习模板,就找这道模板题练最小生成树。既然是模板题,直接看了看样例就模板噼里啪啦
一顿敲·····后来比对结果发现求的不对,这道题要求最小生成树里最大的权值,而我的模板是求最小生成树权值和的。
无大碍,改几下就切掉了,记录下最大权值就行了。
本打算prim和kruskal两个都敲一遍·····后来发现prim算法模板上写的没看懂·····开始着手写份自己的模板····整理中······



完整代码:
#include <functional>
#include <algorithm>
#include <iostream>
#include <fstream>
#include <sstream>
#include <iomanip>
#include <numeric>
#include <cstring>
#include <climits>
#include <cassert>
#include <complex>
#include <cstdio>
#include <string>
#include <vector>
#include <bitset>
#include <queue>
#include <stack>
#include <cmath>
#include <ctime>
#include <list>
#include <set>
#include <map>
using namespace std;

#pragma comment(linker, "/STACK:102400000,102400000")

typedef long long LL;
typedef double DB;
typedef unsigned uint;
typedef unsigned long long uLL;

/** Constant List .. **/ //{

const int MOD = int(1e9)+7;
const int INF = 0x3f3f3f3f;
const LL INFF = 0x3f3f3f3f3f3f3f3fLL;
const DB EPS = 1e-9;
const DB OO = 1e20;
const DB PI = acos(-1.0); //M_PI;
const int maxn = 10001;
int n , m;
int f[maxn];
struct edge
{
    int x , y , w;
    edge(int x = 0 , int y = 0 , int w = 0) : x(x) , y(y) , w(w){}
}e[maxn];

int ans;
int maxx;

bool cmp(edge a , edge b)
{
    return a.w < b.w;
}

int getfather(int x)
{
    return x == f[x] ? x : getfather(f[x]);
}

void kru(int &maxx)
{
    sort(e + 1 , e + m + 1 , cmp);
    int cnt = n;
    for(int i = 1 ; i <= n ; i ++)
    {
        f[i] = i;
    }
    for(int i = 1 ; i <= m ; i ++)
    {
        int t1 = getfather(e[i].x);
        int t2 = getfather(e[i].y);
        if(t1 != t2)
        {
            f[t1] = t2;
            if(e[i].w > maxx)
                maxx = e[i].w;
            ans += e[i].w;
            if(cnt == 1)
                break;
        }
    }
    return ;
}

int main()
{
    #ifdef DoubleQ
    freopen("in.txt","r",stdin);
    #endif
    while(~scanf("%d%d",&n,&m))
    {
        for(int i = 1 ; i <= m ; i ++)
        {
            scanf("%d%d%d",&e[i].x , &e[i].y , &e[i].w);
        }
        maxx = -INF;
        kru(maxx);
        cout << maxx << endl;
    }
}


评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值