HDU-2795-Billboard (线段树)

Billboard



Problem Description
At the entrance to the university, there is a huge rectangular billboard of size h*w (h is its height and w is its width). The board is the place where all possible announcements are posted: nearest programming competitions, changes in the dining room menu, and other important information.

On September 1, the billboard was empty. One by one, the announcements started being put on the billboard.

Each announcement is a stripe of paper of unit height. More specifically, the i-th announcement is a rectangle of size 1 * wi.

When someone puts a new announcement on the billboard, she would always choose the topmost possible position for the announcement. Among all possible topmost positions she would always choose the leftmost one.

If there is no valid location for a new announcement, it is not put on the billboard (that's why some programming contests have no participants from this university).

Given the sizes of the billboard and the announcements, your task is to find the numbers of rows in which the announcements are placed.
 

Input
There are multiple cases (no more than 40 cases).

The first line of the input file contains three integer numbers, h, w, and n (1 <= h,w <= 10^9; 1 <= n <= 200,000) - the dimensions of the billboard and the number of announcements.

Each of the next n lines contains an integer number wi (1 <= wi <= 10^9) - the width of i-th announcement.
 

Output
For each announcement (in the order they are given in the input file) output one number - the number of the row in which this announcement is placed. Rows are numbered from 1 to h, starting with the top row. If an announcement can't be put on the billboard, output "-1" for this announcement.
 

Sample Input
  
  
3 5 5 2 4 3 3 3
 

Sample Output
  
  
1 2 1 3 -1
 



题目大意:

有一个高为h 宽为w 的广告牌,要往上面贴小广告,每个小广告的高都是1 宽为 n,规定每次贴小广告的时候都是从上往下贴,输出该次小广告贴在哪一行。。

这题若是数据不大的话就是一个很简单的模拟题  。。但是数据太大了  又是出现在线段树的专题里  所以要用线段树。。。

但是怎么用线段树呢?

 将广告牌旋转90度来考虑,因为每个小广告的高都为1  将广告牌看成h行每行长为w,旋转90度,这样每一列就是线段树的叶子节点,线段树的叶子节点初始时为w。sum[]数组保存的是最大值;

每次贴小广告的时候与sum[1] 进行比较  如果大于sum[1] 输出-1  如果不大于再去与线段树的叶子节点进行比较  输出具体在那个节点。。OK





#include <iostream>
#include <stdio.h>
#include <string.h>
#include <stdlib.h>
using namespace std;

int h,n,w;
int sum[222222<<2];

int maxx (int a,int b)
{
    return a > b ? a : b;
}

void up (int ii)
{
    sum[ii] = maxx (sum[ii * 2],sum[ii * 2 + 1]);
}

void build (int ii ,int l,int r)
{
    sum[ii] = w;
    if ( l == r )
        return ;
    int mid = (l + r)>>1;
    build (ii*2,l,mid);
    build (ii*2+1,mid +1,r);
}

int query (int ii,int l,int r,int x)
{
    if ( l == r)
    {
        sum[ii] -= x;
        return l;
    }
    int mid = (l + r)/2;
    int ret ;
    if (sum[ii*2] >= x)
        ret = query (ii*2,l,mid,x) ;
    else ret = query (ii * 2 + 1,mid + 1,r,x);
    up (ii);
    return ret;
}

int main()
{
    while (~scanf ("%d%d%d",&h,&w,&n))
    {
        if ( h > n)
            h = n;
        build (1,1,h);
        for (int i = 0; i < n; i++)
        {
            int x;
            scanf ("%d",&x);
            if ( sum[1] < x)
                puts ("-1");
            else
            {
                int ans = query (1,1,h,x);
                printf ("%d\n",ans);
            }
        }
    }
    return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值