Wrong Envelop ---信封装错

Wrong Envelop

Time Limit: 1000ms   Memory limit: 65536K  有疑问?点这里^_^

题目描述

Lin sometimes can be very careless. One day, he wrote n letter(s), but he put each of them in the wrong envelop. How many are the way(s) can he do this identically(different arrangement of the letter-envelop combinations). Because the number can be very big, to avoid the precision problem, modulo each number by 2014.
 

输入

Multiple input cases. n < 250001.
 

输出

The answer.
 

示例输入

1
2
3
4

示例输出

0
1
2
9
 
 
信封装错了。。。好规律的规律。。
#include <stdio.h>
#include <string.h>
long long f[250001];
int main()
{
    int n;
    f[1]=0;
    f[2]=1;
    int i;
    for(i=3;i<=250001;i++)
       {
           f[i]=(i-1)*(f[i-2]+f[i-1]);
           f[i]=f[i]%2014;
       }
    while(scanf("%d",&n)!=EOF)
    {
       printf("%lld\n",f[n]);
    }
    return 0;
}
 



  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值