Surprising Strings(STL)

Surprising StringsCrawling in process...Crawling failedTime Limit:1000MS    Memory Limit:65536KB     64bit IO Format:%I64d & %I64u

Description

The D-pairs of a string of letters are the ordered pairs of letters that are distance D from each other. A string isD-unique if all of its D-pairs are different. A string is surprising if it is D-unique for every possible distance D.

Consider the string ZGBG. Its 0-pairs are ZG, GB, and BG. Since these three pairs are all different, ZGBG is 0-unique. Similarly, the 1-pairs of ZGBG are ZB and GG, and since these two pairs are different, ZGBG is 1-unique. Finally, the only 2-pair of ZGBG is ZG, so ZGBG is 2-unique. Thus ZGBG is surprising. (Note that the fact that ZG is both a 0-pair and a 2-pair of ZGBG is irrelevant, because 0 and 2 are different distances.)

Acknowledgement: This problem is inspired by the "Puzzling Adventures" column in the December 2003 issue ofScientific American.

Input

The input consists of one or more nonempty strings of at most 79 uppercase letters, each string on a line by itself, followed by a line containing only an asterisk that signals the end of the input.

Output

For each string of letters, output whether or not it is surprising using the exact output format shown below.

Sample Input

ZGBG
X
EE
AAB
AABA
AABB
BCBABCC
*

Sample Output

ZGBG is surprising.
X is surprising.
EE is surprising.
AAB is surprising.
AABA is surprising.
AABB is NOT surprising.
BCBABCC is NOT surprising.
 
   
 
   
 
   
题意:一个字符串,在这个字符串中找一对一对的字母,开始是相连的两个字母,那AABB来说,就有三组AA,AB,和BB,然后是中间跳一个字母,就有AB,AB两组数据,最后就只剩下一组数据AB(第一个A和最后一个B)。在这三组测试数据中当中间隔一个字母的那组数据出现了相同的,所以就是not surprising。如果没有出现相同的,就是surprising
ps:多谢丽婧女神的帮助;
 
   
 
   
 
   
 
   
 
   
 
   
 
   
#include <stdio.h>
#include <string.h>
#include <stdlib.h>
#include <algorithm>
#include <map>
#include <queue>
#include <iostream>
#include <string>
using namespace std;
int main()
{
    int n,m,i,j,k,t;
    char str[110];
    int flag;
    map<string,int>::iterator it;//相当于遍历指针;
    while(~scanf("%s",str))
    {
        if(strcmp(str,"*")==0)
            break;
        n=strlen(str);
        if(n==1||n==2)
        {
            printf("%s is surprising.\n",str);//当只有一个字母和两个字母的时候都是没有相同的;
        }
        else
        {
            flag=0;
            k=n-1;
            t=0;
            while(k--)
            {
                map<string,int> G;//为图开辟内存空间
                G.clear();
                for(i=0;i<n-1&&i+t+1<n;i++)
                {
                    string e;//string是个很特殊的函数,它的相加是让它所加的字符串紧跟在它的最后一位;
                    e+=str[i];
                    e+=str[i+t+1];
                    G[e]++;
                }
                for(it=G.begin();it!=G.end();it++)
                {
                    if(it->second!=1)//如果没有相同的 G[e]只能是1,如果不是1,就代表有相同的,就输入surprising
                    {
                        flag=1;
                        break;
                    }
                }
                if(flag==1)
                    break;
                else
                    t++;
            }
            if(flag==0)
                printf("%s is surprising.\n",str);
            else
                 printf("%s is NOT surprising.\n",str);

        }
    }
    return 0;
}

 
   
 
   
 
   
 
  

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包

打赏作者

Rocky0429

一块也是爱

¥1 ¥2 ¥4 ¥6 ¥10 ¥20
扫码支付:¥1
获取中
扫码支付

您的余额不足,请更换扫码支付或充值

打赏作者

实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值