I Think I Need a Houseboat(水题)

107 篇文章 4 订阅
20 篇文章 1 订阅

I Think I Need a Houseboat

Time Limit: 1000ms   Memory limit: 65536K  有疑问?点这里^_^

题目描述

Fred Mapper is considering purchasing some land in Louisiana to build his house on. In the process of
investigating the land, he learned that the state of Louisiana is actually shrinking by 50 square miles each year,
due to erosion caused by the Mississippi River. Since Fred is hoping to live in this house the rest of his life, he
needs to know if his land is going to be lost to erosion.
After doing more research, Fred has learned that the land that is being lost forms a semicircle. This semicircle
is part of a circle centered at (0, 0), with the line that bisects the circle being the X axis. Locations below the X
axis are in the water. The semicircle has an area of 0 at the beginning of year 1. (Semicircle illustrated in the
Figure.)

 

输入

The first line of input will be a positive integer indicating how many data sets will be included (N).
Each of the next N lines will contain the X and Y Cartesian coordinates of the land Fred is considering. These
will be floating point numbers measured in miles. The Y coordinate will be non-negative. (0, 0) will not be
given.
 

输出

 For each data set, a single line of output should appear. This line should take the form of:
Property N: This property will begin eroding in year Z.
Where N is the data set (counting from 1), and Z is the first year (start from 1) this property will be within the
semicircle AT THE END OF YEAR Z. Z must be an integer. After the last data set, this should print out `END
2363 - I Think I Need a Houseboat
1/2
OF OUTPUT.\'.
Notes:
1. No property will appear exactly on the semicircle boundary: it will either be inside or outside.
2. This problem will be judged automatically. Your answer must match exactly, including the
capitalization, punctuation, and white-space. This includes the periods at the ends of the lines.
3. All locations are given in miles.
 

示例输入

2
1.0 1.0
25.0 0.0

示例输出

Property 1: This property will begin eroding in year 1.
Property 2: This property will begin eroding in year 20.
END OF OUTPUT.

提示

 

来源

 Mid Atlantic 2001-2002
 

示例程序

借鉴的网上大牛的题意。

题目大意:弗雷德先生正在考虑在路易斯安娜州买一块地造房子,在土地调查中,他了解到由于密西西比河的侵蚀,路易斯安那州正以每年50平方英里的速度变小。弗雷德先生想知道他买的那块地是否会被侵蚀掉,经过进一步的研究,弗雷德先生发现将要被侵蚀的土地为半圆形,半圆是一个以(0,0)为中心的圆的一半,半圆的直边是x轴。x轴以下的部分在水中,第一年开始时,圆的面积是0,半圆如图所示。第一行输入一个整数n,表示有几组测试数据,接下来有n行,每行是(x,y)的坐标,弗雷德正在考虑地皮的位置,坐标值是以英里为单位的浮点数,坐标y不会为负数,这两个数不会都为0,输出经过多少年后,弗雷德的房子会被淹没


#include <stdio.h>
#include <string.h>
#include <stdlib.h>
#define PI 3.141596
int main()
{
    int n;
    double x,y;
    double area;
    int year;
    scanf("%d",&n);
    for(int i=1;i<=n;i++)
    {
        scanf("%lf %lf",&x,&y);
        area=(x*x+y*y)*PI/2;
        year=area/50;
        printf("Property %d: This property will begin eroding in year %d.\n",i,year+1);
    }
    printf("END OF OUTPUT.\n");
    return 0;
}





评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包

打赏作者

Rocky0429

一块也是爱

¥1 ¥2 ¥4 ¥6 ¥10 ¥20
扫码支付:¥1
获取中
扫码支付

您的余额不足,请更换扫码支付或充值

打赏作者

实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值