Parallelepiped(水题)

Submit Status Practice CodeForces 224A

Description

You've got a rectangular parallelepiped with integer edge lengths. You know the areas of its three faces that have a common vertex. Your task is to find the sum of lengths of all 12 edges of this parallelepiped.

Input

The first and the single line contains three space-separated integers — the areas of the parallelepiped's faces. The area's values are positive ( > 0) and do not exceed 104. It is guaranteed that there exists at least one parallelepiped that satisfies the problem statement.

Output

Print a single number — the sum of all edges of the parallelepiped.

Sample Input

Input
1 1 1
Output
12
Input
4 6 6
Output
28

Sample Output

     
     
301 425 -1
 

Hint

In the first sample the parallelepiped has sizes 1 × 1 × 1, in the second one — 2 × 2 × 3.

题意:给出一个正六面体(其实就是个长方体,一开始没反应过来 sad)  给出三个面的面积s1,s2,s3,让你求出12条边的长度。

思路:先求出长宽高a,b,c来,然后相加*4即可。那么问题来了  如何求。

a*b=s1,a*c=s2,b*c=s3,然后联立就可以了。

#include <stdio.h>
#include <math.h>
#include <string.h>
#include <stdlib.h>
int main()
{
    int s1,s2,s3;
    int a,b,c;
    scanf("%d %d %d",&s1,&s2,&s3);
    a=sqrt(s1*s3/s2);
    b=sqrt(s1*s2/s3);
    c=sqrt(s2*s3/s1);
    int d=(a+b+c)*4;
    printf("%d\n",d);
    return 0;
}


评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包

打赏作者

Rocky0429

一块也是爱

¥1 ¥2 ¥4 ¥6 ¥10 ¥20
扫码支付:¥1
获取中
扫码支付

您的余额不足,请更换扫码支付或充值

打赏作者

实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值