POJ 1068-Parencodings(模拟)

18 篇文章 0 订阅

Parencodings
Time Limit: 1000MS Memory Limit: 10000K
Total Submissions: 20444 Accepted: 12303

Description

Let S = s1 s2...s2n be a well-formed string of parentheses. S can be encoded in two different ways: 
q By an integer sequence P = p1 p2...pn where pi is the number of left parentheses before the ith right parenthesis in S (P-sequence). 
q By an integer sequence W = w1 w2...wn where for each right parenthesis, say a in S, we associate an integer which is the number of right parentheses counting from the matched left parenthesis of a up to a. (W-sequence). 

Following is an example of the above encodings: 
	S		(((()()())))

	P-sequence	    4 5 6666

	W-sequence	    1 1 1456


Write a program to convert P-sequence of a well-formed string to the W-sequence of the same string. 

Input

The first line of the input contains a single integer t (1 <= t <= 10), the number of test cases, followed by the input data for each test case. The first line of each test case is an integer n (1 <= n <= 20), and the second line is the P-sequence of a well-formed string. It contains n positive integers, separated with blanks, representing the P-sequence.

Output

The output file consists of exactly t lines corresponding to test cases. For each test case, the output line should contain n integers describing the W-sequence of the string corresponding to its given P-sequence.

Sample Input

2
6
4 5 6 6 6 6
9 
4 6 6 6 6 8 9 9 9

Sample Output

1 1 1 4 5 6
1 1 2 4 5 1 1 3 9

思路:b[i]表示第i和i+1个右括号之间有多少个括号,然后逐渐找和右括号匹配的左括号的位置。

#include <stdio.h>
#include <string.h>
#include <stdlib.h>
#include <algorithm>
using namespace std;
int main()
{
        int T,n,i,j;
        int a[110],b[110],c[110];
        scanf("%d",&T);
        while(T--) {
                scanf("%d",&n);
                for(i=1; i<=n; i++) {
                        scanf("%d",&a[i]);
                }
                b[0]=a[1];
                for(i=1; i<n; i++) {
                        b[i]=a[i+1]-a[i];
                }
                for(i=1; i<=n; i++) {
                        for(j=i-1; j>=0; j--) {
                                if(b[j]>0) {
                                        b[j]--;
                                        break;
                                }
                        }
                        c[i]=i-j;
                }
                for(i=1; i<n; i++)
                        printf("%d ",c[i]);
                printf("%d\n",c[i]);
        }
        return 0;
}


评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包

打赏作者

Rocky0429

一块也是爱

¥1 ¥2 ¥4 ¥6 ¥10 ¥20
扫码支付:¥1
获取中
扫码支付

您的余额不足,请更换扫码支付或充值

打赏作者

实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值